This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 975648 - [abrt] system-config-printer-libs-1.4.1-6.fc19: jobviewer.py:1792:notify_completed_job:TypeError: GObject.__init__() takes exactly 0 arguments (3 given)
[abrt] system-config-printer-libs-1.4.1-6.fc19: jobviewer.py:1792:notify_comp...
Status: CLOSED DUPLICATE of bug 974845
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:df443bf4037e56dde44e917d8bf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 23:27 EDT by Chuck Forsberg
Modified: 2013-06-20 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 06:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.21 KB, text/plain)
2013-06-18 23:27 EDT, Chuck Forsberg
no flags Details
File: core_backtrace (223 bytes, text/plain)
2013-06-18 23:27 EDT, Chuck Forsberg
no flags Details
File: environ (1009 bytes, text/plain)
2013-06-18 23:27 EDT, Chuck Forsberg
no flags Details

  None (edit)
Description Chuck Forsberg 2013-06-18 23:27:03 EDT
Version-Release number of selected component:
system-config-printer-libs-1.4.1-6.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/share/system-config-printer/scp-dbus-service.py
executable:     /usr/share/system-config-printer/scp-dbus-service.py
kernel:         3.9.6-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
jobviewer.py:1792:notify_completed_job:TypeError: GObject.__init__() takes exactly 0 arguments (3 given)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/jobviewer.py", line 2028, in job_removed
    self.notify_completed_job (jobid)
  File "/usr/share/system-config-printer/jobviewer.py", line 1792, in notify_completed_job
    'printer')
TypeError: GObject.__init__() takes exactly 0 arguments (3 given)

Local variables in innermost frame:
printer_uri: u'ipp://localhost.localdomain/printers/HP-Color-LaserJet-2605dn'
c: <authconn.Connection instance at 0x1e819e0>
printer: 'HP-Color-LaserJet-2605dn'
pattrs: ['device-uri']
self: <JobViewer object at 0x1e15460 (jobviewer+JobViewer at 0x1c88340)>
rest: u'//192.168.1.12:9100'
jobid: 10
job: {'job-name': u'(stdin)', 'job-printer-uri': u'ipp://localhost.localdomain/printers/HP-Color-LaserJet-2605dn', 'attributes-natural-language': u'en-us', 'job-printer-name': 'HP-Color-LaserJet-2605dn', 'time-at-creation': 1371612332, 'job-originating-user-name': u'root', 'attributes-charset': u'utf-8', 'job-state': 5, 'job-k-octets': 1}
attrs: {'device-uri': u'socket://192.168.1.12:9100'}
device_uri: u'socket://192.168.1.12:9100'
scheme: u'socket'
document: u'(stdin)'
Comment 1 Chuck Forsberg 2013-06-18 23:27:08 EDT
Created attachment 762686 [details]
File: backtrace
Comment 2 Chuck Forsberg 2013-06-18 23:27:11 EDT
Created attachment 762687 [details]
File: core_backtrace
Comment 3 Chuck Forsberg 2013-06-18 23:27:14 EDT
Created attachment 762688 [details]
File: environ
Comment 4 Jiri Popelka 2013-06-19 06:49:56 EDT
Should be fixed upstream with
https://git.fedorahosted.org/cgit/system-config-printer.git/commit/?id=d6ad52b9e9f43ef3484167ef0e59f7a34bc322bd

*** This bug has been marked as a duplicate of bug 974845 ***

Note You need to log in before you can comment on or make changes to this bug.