Bug 975010 - Fedora19 beta kickstart error in partitioning
Fedora19 beta kickstart error in partitioning
Status: CLOSED DUPLICATE of bug 966761
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 07:49 EDT by Derrien
Modified: 2013-06-17 11:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 10:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.storage.log (112.04 KB, text/x-log)
2013-06-17 07:49 EDT, Derrien
no flags Details

  None (edit)
Description Derrien 2013-06-17 07:49:08 EDT
Created attachment 762011 [details]
anaconda.storage.log

Description of problem:

We are asking for 3 partitions in kickstart file :

clearpart --linux --drives=sda
#
part / --label=ROOT --fstype ext4 --size 35000
part swap --label=SWAP --recommended
part /home --label=HOME --fstype ext4 --size 100 --grow
#

we get 4 partitions

[root (Fedora 19) ~]$ fdisk -l /dev/sda

Disk /dev/sda: 160.0 GB, 160041885696 bytes, 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x0004275c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    71682047    35840000   83  Linux
/dev/sda2        71682048    75909119     2113536   83  Linux
/dev/sda3        75909120    80136191     2113536   82  Linux swap / Solaris
/dev/sda4        80136192   312581807   116222808    5  Extended
/dev/sda5        80138240   312580095   116220928   83  Linux

Why the partition sda2 ? (same size as swap partition sda3)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Lehman 2013-06-17 10:23:24 EDT
This looks like the same root cause as bug 966761. Please retest with anaconda-19.30.7-1.fc19 or later and report any recurrence of the bug there.

*** This bug has been marked as a duplicate of bug 966761 ***
Comment 2 Derrien 2013-06-17 11:23:38 EDT
Could you explain me how to test that ?
I see : "This will be in the next test compose" 
Where can I find this ?

Note You need to log in before you can comment on or make changes to this bug.