Bug 966761 - storage configuration failed: Not enough free space on disks for automatic partitioning
Summary: storage configuration failed: Not enough free space on disks for automatic pa...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: ppc64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords: Reopened
: 969327 974160 975010 975652 (view as bug list)
Depends On:
Blocks: F19Blocker, F19FinalBlocker F19PPCFinal, F19PPCFinalBlocker, PPCFinalBlocker 973595
TreeView+ depends on / blocked
 
Reported: 2013-05-23 21:54 UTC by Mark Hamzy
Modified: 2013-06-21 01:34 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-06-18 19:59:39 UTC


Attachments (Terms of Use)
anaconda.log (10.71 KB, text/x-log)
2013-05-23 21:54 UTC, Mark Hamzy
no flags Details
storage.log (268.60 KB, text/plain)
2013-05-23 21:55 UTC, Mark Hamzy
no flags Details
program.log (62.88 KB, text/plain)
2013-05-23 21:56 UTC, Mark Hamzy
no flags Details
syslog (56.69 KB, text/plain)
2013-05-23 21:56 UTC, Mark Hamzy
no flags Details

Description Mark Hamzy 2013-05-23 21:54:33 UTC
Created attachment 752400 [details]
anaconda.log

Booting http://ppc.koji.fedoraproject.org/stage/f19-20130523-Beta-RC4.1/ppc64/iso/Fedora-19-ppc64-DVD.iso with the following command line:

boot: linux inst.vnc inst.sshd ip=9.5.114.36::9.5.114.1:255.255.255.0:sharpie.rch.stglabs.ibm.com:eth0:none ip=9.5.114.41::9.5.114.1:255.255.255.0::eth1:none nameserver=9.10.244.100 bootdev=eth0 ks=http://chukar.rch.stglabs.ibm.com/Fedora19-sharpie-lvm_auto-cdrom-minimal-ks.cfg

The kickstart file is:

8<-----8<-----8<-----8<-----8<-----8<-----
#version=DEVEL
# System authorization information
auth --enableshadow --passalgo=sha512
# Use CDROM installation media
cdrom

# Run the Setup Agent on first boot
firstboot --enable
ignoredisk --only-use=sda
# Keyboard layouts
keyboard --vckeymap=us --xlayouts='us'
# System language
lang en_US.UTF-8

# Network information
network  --bootproto=static --device=eth0 --gateway=9.5.114.1 --ip=9.5.114.36 --nameserver=9.10.244.100 --netmask=255.255.255.0 --noipv6 --activate --hostname=sharpie.rch.stglabs.ibm.com
network  --bootproto=static --device=eth1 --gateway=9.5.114.1 --ip=9.5.114.41 --nameserver=9.10.244.100 --netmask=255.255.255.0 --noipv6 --activate
# Root password
rootpw  --iscrypted $6$FCC2q6uYlfUbj/yT$DofkzfLSx81naeiFN/s8QmQrg3OEqX4B8M3balQqKIqr93d43qGSk778ia/fffLdV.WWR7C9JaNrsNzv/BFy50
# System services
services --enabled="chronyd"
# System timezone
timezone America/Chicago --isUtc
user --groups=wheel --name=hamzy --password=$6$G5rAVxJJu96EVjMT$seDbnccXanXj21XXRIcFYaueoP83aGy1SGbiRt1b1fwA3fITSd6VsVnRIS3urA8f8940lg4t466Q3p439eSU70 --iscrypted --gecos="Mark Hamzy"

# System bootloader configuration
bootloader --location=mbr --boot-drive=sda
clearpart --all --initlabel --drives=sda
# Partition clearing information
autopart --type=lvm

%packages
@core
@standard

%end
8<-----8<-----8<-----8<-----8<-----8<-----

Does not proceed to installation.  Instead, the following error is displayed:

storage configuration failed: Not enough free space on disks for automatic partitioning

Comment 1 Mark Hamzy 2013-05-23 21:55:48 UTC
Created attachment 752401 [details]
storage.log

Comment 2 Mark Hamzy 2013-05-23 21:56:25 UTC
Created attachment 752403 [details]
program.log

Comment 3 Mark Hamzy 2013-05-23 21:56:53 UTC
Created attachment 752404 [details]
syslog

Comment 4 Mark Hamzy 2013-05-23 21:59:56 UTC
The kickstart file worked back when it had one virtual scsi drive.  Now it has 3: sda, sdb, and sdc.  Although only one is mentioned in the kickstart file.

Comment 5 David Lehman 2013-05-24 15:08:01 UTC
It looks like the storage execute thread is running twice. Chris thinks it is related to the fact that the storage spoke's changed property is now always true.

Comment 6 Mark Hamzy 2013-05-28 16:52:59 UTC
Proposing as a FinalBlocker:

"The installer must be able to use all available kickstart delivery methods."

Comment 7 Chris Lumens 2013-05-28 20:47:32 UTC
I was definitely able to reproduce this on Friday, but not so much today.  Can you please retest with whatever the next image is and let me know?  Thanks.

Comment 8 Adam Williamson 2013-05-29 16:42:50 UTC
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . As we're waiting for info from the reporter, we'll delay evaluation of this for now.

Comment 9 Mark Hamzy 2013-06-05 14:34:53 UTC
Ran into bug 971046 trying to see if this still happens.

Comment 10 Adam Williamson 2013-06-05 16:59:18 UTC
Discussed at 2013-06-05 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-05/f19final-blocker-review-3.2013-06-05-16.05.log.txt .  We are still waiting for information to figure out whether this is affecting multiple configurations or if it's specific to Mark's config in some way. (We appreciate that you're trying, Mark, I'm just doin' bureaucracy here :>)

Comment 11 Mark Hamzy 2013-06-07 15:56:04 UTC
I tested a private build of anaconda-19.30.3-1.fc19 and mozjs17-17.0.0-4.fc19.kh.ppc64 (to fix the GError) and it still fails for me.

Comment 12 Adam Williamson 2013-06-10 16:30:47 UTC
Discussed again at 2013-06-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-10/f19final-blocker-review-4.2013-06-10-16.01.log.txt . We will see if this can be reproduced on a primary arch before deciding whether it is a blocker. Mark, if there are any unique elements of the machine's configuration besides those described above, it might help us reproduce the issue.

Comment 13 Mark Hamzy 2013-06-10 18:20:15 UTC
From the meeting notes, it sounds like kparal can reproduce this on PA:

16:24:10 <adamw> i guess we do need to see if anyone else can hit it now, though
16:25:49 <dgilmore> yeah
16:25:49 * kparal running it
16:26:03 <tflink> proposed #agreed - This has been reproduced on ppc but it needs to be reproduced on PA before taking it as a blocker. will revisit when more information is available
16:26:23 <tflink> unless we want to wait for kparal's run to finish
16:26:50 <tflink> wasn't there also a question about whether ks was sequential or not - ie, the order or part and clearpart?
16:27:43 <adamw> ack
16:27:50 <dgilmore> ack
16:27:54 <adamw> possibly, but that's probably just me guessing stuff
16:28:27 <tflink> other ack/nak/patch?
16:28:29 <jreznik> ack
...
16:29:00 * kparal is experiencing technical difficulties
...
16:29:36 <kparal> I got usual "no disks selected"

This is what I see for my kickstart install:

http://hamzy.fedorapeople.org/969327-1.png

Then, going into "Installation Destination" and selecting "click for details," I see:

http://hamzy.fedorapeople.org/969327-2.png

I asked kparal about this and sees the same thing:

<kparal> yes, I see the same
<kparal> it might be the same bug

The bug kparal is talking about is bug 969327. Can someone from the anaconda team comment about this?

Comment 14 Mark Hamzy 2013-06-10 18:22:12 UTC
Adam,

One unique thing about the setup is this is on an LPAR with 3 virtual scsi disks with installation only referencing one of said disks.

Comment 15 Adam Williamson 2013-06-10 18:53:14 UTC
mark: what I read 'usual no disks selected' as meaning was that kparal hit this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=969327

we were pontificating that that bug, this bug, and https://bugzilla.redhat.com/show_bug.cgi?id=967527 might all be closely related and/or have the same underlying cause, but we're not entirely sure yet.

Comment 16 Chris Lumens 2013-06-13 19:45:53 UTC
*** Bug 969327 has been marked as a duplicate of this bug. ***

Comment 17 Kamil Páral 2013-06-14 08:51:34 UTC
Transferring AcceptedBlocker from bug 969327.

Comment 18 Chris Lumens 2013-06-14 14:21:32 UTC
*** Bug 974160 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2013-06-14 16:45:30 UTC
pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19

Comment 20 ajs 2013-06-14 21:17:30 UTC
Is there a updates.img URL that I could point to in my kickstart file to test the update?

Comment 21 Chris Lumens 2013-06-14 21:19:12 UTC
This will be in the next test compose, which you can just try out there.  Please don't change the bug state.

Comment 22 ajs 2013-06-14 21:36:48 UTC
Sorry about changing the bug status.  I'm not sure how that happened.

Comment 23 Fedora Update System 2013-06-15 17:07:07 UTC
Package anaconda-19.30.7-1.fc19, pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.7-1.fc19 pykickstart-1.99.32-1.fc19 python-blivet-0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10913/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.7-1.fc19
then log in and leave karma (feedback).

Comment 24 David Lehman 2013-06-17 14:23:24 UTC
*** Bug 975010 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2013-06-18 06:16:38 UTC
pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19, anaconda-19.30.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Kamil Páral 2013-06-18 10:32:21 UTC
Mark, can you please re-test this with F19 TC5? Thanks!

Comment 27 Mark Hamzy 2013-06-18 19:10:22 UTC
I tested with http://ppc.koji.fedoraproject.org/stage/f19-20130618-GA-TC5.1/ppc64/iso/Fedora-19-ppc64-DVD.iso and it works for me.

Comment 28 Adam Williamson 2013-06-18 19:59:39 UTC
Great, then we can close it! Thanks.

Comment 29 Brian Lane 2013-06-21 01:34:32 UTC
*** Bug 975652 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.