Bug 975030 - turpial's cannot authenticate any more
turpial's cannot authenticate any more
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: turpial (Show other bugs)
20
All Linux
high Severity high
: ---
: ---
Assigned To: Edwind Richzendy Contreras Soto
Fedora Extras Quality Assurance
:
: 1005844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 08:59 EDT by Michele Baldessari
Modified: 2014-01-03 09:57 EST (History)
4 users (show)

See Also:
Fixed In Version: turpial-3.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-31 04:52:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Baldessari 2013-06-17 08:59:47 EDT
Description of problem:
I believe twitter depreacted some APIs (https://dev.twitter.com/blog/api-v1-is-retired) hence turpial does not authenticate anymore:

$ turpial 
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
No module named indicate

** (turpial:28970): CRITICAL **: gst_is_missing_plugin_message: assertion `GST_IS_MESSAGE (msg)' failed
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/turpial/api/protocols/twitter/http.py", line 128, in request
    rtn = self.do_request(uri, args)
  File "/usr/lib/python2.7/site-packages/turpial/api/interfaces/http.py", line 187, in do_request
    response = self.__send(authreq)
  File "/usr/lib/python2.7/site-packages/turpial/api/interfaces/http.py", line 159, in __send
    handle = urllib2.urlopen(req)
  File "/usr/lib64/python2.7/urllib2.py", line 127, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib64/python2.7/urllib2.py", line 410, in open
    response = meth(req, response)
  File "/usr/lib64/python2.7/urllib2.py", line 523, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib64/python2.7/urllib2.py", line 448, in error
    return self._call_chain(*args)
  File "/usr/lib64/python2.7/urllib2.py", line 382, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.7/urllib2.py", line 531, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 410: Gone


Version-Release number of selected component (if applicable):
turpial-1.6.9-3.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. start turpial (happens since 1 or 2 weeks)
2.
3.

Actual results:
Cannot log on. "Authentication Error"

Expected results:


Additional info:
Comment 1 Edwind Richzendy Contreras Soto 2013-06-17 09:05:09 EDT
Yes, that is the problem, the 1.0 api version it's out from twitter, I hope to new turpial version coming soon with 1.1 api version support.

https://github.com/Turpial/Turpial/issues/73
Comment 2 Ankur Sinha (FranciscoD) 2013-11-03 21:54:45 EST
Also seen on F20:

turpial-1.6.9-4.fc20.noarch

Unfortunately, this makes the app unusable at the moment for Twitter at least :/
Comment 3 Edwind Richzendy Contreras Soto 2013-12-09 21:16:07 EST
I'm working right now on a new turpial version (3.0)[1] rpm package and libturpial (python backend library to turpial > 3.0), this version has full support to new twitter api version.

I will have (hope) turpial back again to Fedora 20 release.

Thanks for your pacience

[1] http://turpial.org.ve/2013/12/second-beta-release-for-turpial-3/
Comment 4 Edwind Richzendy Contreras Soto 2013-12-30 21:04:29 EST
*** Bug 1005844 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-12-30 21:11:47 EST
turpial-3.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/turpial-3.0-3.fc20
Comment 6 Fedora Update System 2013-12-30 21:14:02 EST
turpial-3.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/turpial-3.0-3.fc19
Comment 7 Fedora Update System 2013-12-31 04:52:57 EST
turpial-3.0-3.fc20 has been pushed to the Fedora 20 stable repository.
Comment 8 Fedora Update System 2014-01-03 09:57:44 EST
turpial-3.0-3.fc19 has been pushed to the Fedora 19 stable repository.

Note You need to log in before you can comment on or make changes to this bug.