Bug 975057 - [katello-glue-pulp] cron for refreshing cdn content fails: rake: command not found
[katello-glue-pulp] cron for refreshing cdn content fails: rake: command not ...
Status: CLOSED DUPLICATE of bug 998541
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
: 1003095 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 10:14 EDT by Garik Khachikyan
Modified: 2015-01-04 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 00:22:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2013-06-17 10:14:30 EDT
Description of problem:
Accidentally hit following under my: /var/spool/mail/root
===
/etc/cron.daily/katello-refresh-cdn:

/etc/cron.daily/katello-refresh-cdn: line 9: rake: command not found
===

More details showed that we seems have a cron setup under: /etc/cron.daily/katello-refresh-cdn which belongs to katello-glue-pulp

Version-Release number of selected component (if applicable):
katello-glue-pulp-1.4.2-14.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-sun-x4440-01.rhts.eng.bos.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-14.el6sat.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-all-1.4.2-14.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-common-1.4.2-14.el6sat.noarch
katello-configure-1.4.3-16.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
katello-foreman-all-1.4.2-14.el6sat.noarch
katello-glue-candlepin-1.4.2-14.el6sat.noarch
katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.2-0.3.beta.el6sat.noarch
pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
pulp-server-2.1.2-0.3.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.2-0.3.beta.el6sat.noarch
python-pulp-common-2.1.2-0.3.beta.el6sat.noarch
python-pulp-rpm-common-2.1.2-0.3.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-5.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
signo-katello-0.0.18-1.el6sat.noarch

How reproducible:
from the first attempt

Steps to Reproduce:
1. just run: /etc/cron.daily/katello-refresh-cdn
2.
3.

Actual results:
/etc/cron.daily/katello-refresh-cdn: line 9: rake: command not found

Expected results:
donno :) not failing at least with stderr

Additional info:
Comment 2 Mikkilineni Suresh Babu 2013-07-25 03:51:34 EDT
I had similar issue when I did katello-configure. symbolic link of /opt/rh/ruby193/root/usr/bin/rake to /usr/bin/ worked for me. 

#ln -s /opt/rh/ruby193/root/usr/bin/rake /usr/bin/
Comment 3 Mike McCune 2013-09-02 12:01:20 EDT
*** Bug 1003095 has been marked as a duplicate of this bug. ***
Comment 4 Mike McCune 2013-10-22 00:22:14 EDT
\

*** This bug has been marked as a duplicate of bug 998541 ***

Note You need to log in before you can comment on or make changes to this bug.