Bug 975204 - radeon card lost opengl 3.1 support
Summary: radeon card lost opengl 3.1 support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 974316 (view as bug list)
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-06-17 19:50 UTC by Simon Putt
Modified: 2013-06-20 05:58 UTC (History)
7 users (show)

Fixed In Version: mesa-9.2-0.12.20130610.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-20 05:58:48 UTC


Attachments (Terms of Use)

Description Simon Putt 2013-06-17 19:50:57 UTC
Description of problem:

latest update of mesa-9.2-0.11.20130610.fc19 (dated 17th June) lost OpenGL 3.1 support for my Radeon card. Previous version showed correct support of OpenGL 3.1


Version-Release number of selected component (if applicable):

mesa-9.2-0.11.20130610.fc19

How reproducible:

always


Steps to Reproduce:
1.
2.
3.

Actual results:

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD TURKS
OpenGL version string: 2.1 Mesa 9.2.0-devel
OpenGL shading language version string: 1.30


Expected results:

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD TURKS
OpenGL version string: 3.1 Mesa 9.2.0-devel
OpenGL shading language version string: 1.40


Additional info:

Comment 1 Fedora Update System 2013-06-17 20:11:38 UTC
mesa-9.2-0.12.20130610.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mesa-9.2-0.12.20130610.fc19

Comment 2 Sandro Mani 2013-06-18 11:21:49 UTC
*** Bug 974316 has been marked as a duplicate of this bug. ***

Comment 3 Adam Jackson 2013-06-18 15:53:08 UTC
This is possibly more of a Freeze Exception than a Blocker, but it'd be really quite nice to have this working on big-endian too.

Comment 4 Kamil Páral 2013-06-19 08:47:19 UTC
Simon, the fixed build is in updates-testing repository. Can you please verify whether this fixes the problem for you?

Comment 5 Adam Williamson 2013-06-19 16:58:41 UTC
Discussed at 2013-06-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-19/f19final-blocker-review-7.2013-06-19-16.01.log.txt . We don't see any grounds for taking this as a blocker - apparently it doesn't break essential functionality, i.e. Shell - but it's an obvious error that breaks expected functionality so it's accepted as a freeze exception issue. Note that the fix is included in Final TC5 already.

Comment 6 Fedora Update System 2013-06-20 05:58:48 UTC
mesa-9.2-0.12.20130610.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.