Bug 97553 - exmh doesn't handle UTF8 message
exmh doesn't handle UTF8 message
Status: CLOSED DUPLICATE of bug 89110
Product: Red Hat Linux
Classification: Retired
Component: exmh (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-06-17 13:18 EDT by Tethys
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot (20.84 KB, image/png)
2003-06-17 13:20 EDT, Tethys
no flags Details

  None (edit)
Description Tethys 2003-06-17 13:18:57 EDT
Description of problem:

When viewing Red Hat Bugzilla email, it every character is followed
by a dotted square. This is because it's treating the message as
normal ASCII/Latin1 text, rather than the UTF-8 that it is (and
that's stated in the headers).

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Look at a RH bugzilla email in exmh
Actual results:
See attached screenshot

Expected results:

Additional info:
This is with RH9. Curiously, though, if I ssh into an RH7 box with
exmh-2.4-2, and run it X displaying to my local machine, it all looks
fine, and seems to handle the UTF8 without problems. The only relevant
environment variable are $LANG (which is en_US on RH7.2 and en_US.UTF-8
on RH9) an $LC_COLLATE (which shouldn't be relevant, but is set to C on
both machines).
Comment 1 Tethys 2003-06-17 13:20:07 EDT
Created attachment 92451 [details]
Comment 2 Brent Fox 2004-04-16 17:39:11 EDT

*** This bug has been marked as a duplicate of 89110 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.