Bug 975598 - Scala package has broken osgi dependency [NEEDINFO]
Scala package has broken osgi dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scala (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Geoff Reedy
Fedora Extras Quality Assurance
:
: 984149 984150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 17:33 EDT by Egor Kuropatkin
Modified: 2013-12-13 22:24 EST (History)
19 users (show)

See Also:
Fixed In Version: scala-2.10.3-8.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 10:42:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dkholia: needinfo? (geoff+fedora)


Attachments (Terms of Use)
yum output (1.50 KB, text/x-log)
2013-06-18 17:33 EDT, Egor Kuropatkin
no flags Details

  None (edit)
Description Egor Kuropatkin 2013-06-18 17:33:41 EDT
Created attachment 762644 [details]
yum output

Description of problem:
Upon installing scala through 'yum install scala' the following error message appears:

Error: Package: scala-2.9.2-2.fc19.noarch (fedora)
           Requires: osgi(org.scala-ide.scala.library)
Comment 1 Jim Carpenter 2013-06-25 02:09:12 EDT
scala-2.9.2-4.fc18 currently has a dependency on osgi too. I thought it was fixed in 2.9.2-3.
Comment 2 Dhiru Kholia 2013-07-09 13:25:19 EDT
Geoff,

Is there any progress on this bug?

Are you working on fixing it?
Comment 3 Mat Booth 2013-07-23 09:54:21 EDT
*** Bug 984150 has been marked as a duplicate of this bug. ***
Comment 4 Mat Booth 2013-07-23 09:54:23 EDT
*** Bug 984149 has been marked as a duplicate of this bug. ***
Comment 5 Mariusz Smykuła 2013-08-27 14:31:42 EDT
Nice bug, maybe this will be fixed in Fedora 20...
Comment 6 Jared Sprague 2013-08-28 23:17:16 EDT
I just tried to "yum install scala" on a fresh install of Fedora 19 and it fails.

here is the log:

[root@localhost ~]# yum install scala
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
fedora/19/x86_64/filelists_db                                                                                                                                                               |  25 MB  00:00:05     
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
--> Processing Dependency: jline2 for package: scala-2.9.2-2.fc19.noarch
--> Processing Dependency: /usr/share/java/jline2.jar for package: scala-2.9.2-2.fc19.noarch
http://fedora.mirror.lstn.net/updates/19/x86_64/repodata/550f89e4ce4e714e7487b04fb961fc819fd7a4a67094d3ec9a14e0dc7d5617de-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://fedora.mirror.constant.com/linux/updates/19/x86_64/repodata/550f89e4ce4e714e7487b04fb961fc819fd7a4a67094d3ec9a14e0dc7d5617de-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror.pnl.gov/fedora/linux/updates/19/x86_64/repodata/550f89e4ce4e714e7487b04fb961fc819fd7a4a67094d3ec9a14e0dc7d5617de-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
ftp://mirror.lstn.net/fedora/updates/19/x86_64/repodata/550f89e4ce4e714e7487b04fb961fc819fd7a4a67094d3ec9a14e0dc7d5617de-filelists.sqlite.bz2: [Errno 14] FTP Error 550 - Given file does not exist
Trying other mirror.
updates/19/x86_64/filelists_db                                                                                                                                                              |  11 MB  00:00:28     
--> Processing Dependency: /usr/share/java/jansi.jar for package: scala-2.9.2-2.fc19.noarch
--> Running transaction check
---> Package jansi.noarch 0:1.9-3.fc19 will be installed
--> Processing Dependency: jansi-native for package: jansi-1.9-3.fc19.noarch
--> Processing Dependency: hawtjni for package: jansi-1.9-3.fc19.noarch
---> Package jline2.noarch 0:2.10-6.fc19 will be installed
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
--> Running transaction check
---> Package hawtjni.noarch 0:1.6-4.fc19 will be installed
--> Processing Dependency: xbean for package: hawtjni-1.6-4.fc19.noarch
--> Processing Dependency: apache-commons-cli for package: hawtjni-1.6-4.fc19.noarch
---> Package jansi-native.x86_64 0:1.4-5.fc19 will be installed
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
--> Running transaction check
---> Package apache-commons-cli.noarch 0:1.2-9.fc19 will be installed
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
---> Package xbean.noarch 0:3.13-1.fc19 will be installed
--> Processing Dependency: slf4j for package: xbean-3.13-1.fc19.noarch
--> Running transaction check
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
---> Package slf4j.noarch 0:1.7.4-1.fc19 will be installed
--> Processing Dependency: mvn(ch.qos.cal10n:cal10n-api) for package: slf4j-1.7.4-1.fc19.noarch
--> Running transaction check
---> Package cal10n.noarch 0:0.7.7-1.fc19 will be installed
---> Package scala.noarch 0:2.9.2-2.fc19 will be installed
--> Processing Dependency: osgi(org.scala-ide.scala.library) for package: scala-2.9.2-2.fc19.noarch
--> Finished Dependency Resolution
Error: Package: scala-2.9.2-2.fc19.noarch (fedora)
           Requires: osgi(org.scala-ide.scala.library)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]#
Comment 7 larsh 2013-08-29 00:38:37 EDT
It would be nice if there would be some update on this bug in some form. Even a "won't fix for F19" is better than no information.

Is somebody working on it?
Will there be an attempt to fix this in F19?
If not, can we just remove the Scala package from the repositories rather than keeping the broken one there?
Comment 8 Dhiru Kholia 2013-08-29 03:35:06 EDT
Hi larsh,

From what I hear, this bug is going be fixed on the same day "Duke Nukem Forever 2" is getting released.

On a more serious note, I have started using upstream Scala binary releases. This is what you might end up doing too.

If you talk to Scala folks on IRC, they recommend using the upstream "vetted" binary releases. In fact, some "pragmatic" distributions EVEN ship upstream binary releases (and Scala folks are happy with this approach).
Comment 9 Jack Perdue 2013-09-27 21:56:08 EDT
 yum install scala --releasever=18

seems to be the workaround for the moment on fc19.  I tried releasever=20 also with no luck, so either they've dropped it or they are still having problems with it.

So, try that or comment #8 (: which was a good one :)
Comment 10 Jim Carpenter 2013-09-28 02:45:26 EDT
(In reply to Jack Perdue from comment #9)
>  yum install scala --releasever=18
> 
> seems to be the workaround for the moment on fc19.  

That doesn't seem right. I'm still running 18 here and I'm having the same dependency problem. (maybe you meant 17?)

Does this package no longer have a maintainer????
Comment 11 Jack Perdue 2013-09-28 12:42:41 EDT
It worked here... YMMV...

# yum -y --releasever=18 install scala-examples --disablerepo=\*myrepos\* --nogpgcheck

# rpm -qa | sort | grep -C3 scala-
sat4j-2.3.5-1.fc19.noarch
satyr-0.9-1.fc19.x86_64
sbc-1.0-3.fc19.x86_64
scala-2.9.2-4.fc18.noarch
scala-examples-2.9.2-4.fc18.noarch
scalapack-common-1.7.5-19.fc19.x86_64
scalapack-mpich-1.7.5-19.fc19.x86_64
scalapack-mpich-devel-1.7.5-19.fc19.x86_64
Comment 12 Jim Carpenter 2013-09-30 09:16:19 EDT
(In reply to Jack Perdue from comment #11)
> It worked here... YMMV...

You're right. This bug is so old I forgot the details!

Both 19 and 18 have the OSGI dependency, but with Fedora 18 the dependencies can be installed.
Comment 13 Jochen Schmitt 2013-10-12 10:42:05 EDT
Should be fixed in scala-2.10.3-1.fc19.
Comment 14 Antoine Gourlay 2013-11-19 10:13:31 EST
scala 2.10.3-2.fc19 still has a weird osgi dependency in F19:

# yum deplist scala
package: scala.noarch 2.10.3-2.fc19

* snip *

dependency: osgi(org.apache.ant)
   provider: eclipse-platform.x86_64 1:4.3.1-5.fc19


And eclipse-platform pulls in a very long list of packages (70+, ~100M) that are completely irrelevant to scala. Is this dependency really necessary?

Same thing with 2.10.3-7.fc20.
Comment 15 Fedora Update System 2013-11-27 14:53:05 EST
scala-2.10.3-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scala-2.10.3-8.fc20
Comment 16 Fedora Update System 2013-11-27 14:54:33 EST
scala-2.10.3-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scala-2.10.3-8.fc19
Comment 17 lnie 2013-11-27 21:57:23 EST
scala-2.10.3-8.fc20 seems fine,only 25 dependency packages needed.Compare with the last version's 107 dependency packages,it works pretty fine.
Comment 18 Fedora Update System 2013-12-08 21:04:31 EST
scala-2.10.3-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-12-13 22:24:39 EST
scala-2.10.3-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.