Bug 975652 - Anaconda Kickstart + Creating a btrfs volume issues
Anaconda Kickstart + Creating a btrfs volume issues
Status: CLOSED DUPLICATE of bug 966761
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 973595
  Show dependency treegraph
 
Reported: 2013-06-18 23:53 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 21:34:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-06-18 23:53:12 EDT
Description of problem:

I want to create a btrfs volume in my kickstart file apart from the ones needed for installing the OS (Fedora 19) (assume ext4 for those).

These are the relevant lines from my kickstart file:


clearpart --all --initlabel
part / --fstype=ext4 --size=5000
part /boot --fstype=ext4 --size=500
part swap --recommended

part btrfs.01 --size=1024
btrfs none --label=f17 btrfs.01

I expect this to work as per [1]. However, it doesn't. Here is the traceback:


anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 789, in create
    raise DeviceCreateError(str(e), self.name)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 272, in execute
    self.device.create()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceCreateError: ('1', 'f17')

Local variables in innermost frame:
self: non-existent 1024MB btrfs volume f17 (13) with non-existent btrfs filesystem
e: 1

Here is the anaconda-tb-OwFcOY file [2]. These lines seem really strange to me:

23:14:00,396 INFO program: Running... mkfs.btrfs --label=f17 /dev/vda7
23:14:00,458 INFO program:
23:14:00,460 INFO program: WARNING! - Btrfs v0.20-rc1 IS EXPERIMENTAL
23:14:00,461 INFO program: WARNING! - see http://btrfs.wiki.kernel.org before using
23:14:00,462 INFO program:
23:14:00,463 INFO program: fs created label f17 on /dev/vda7
23:14:00,465 INFO program:      nodesize 4096 leafsize 4096 sectorsize 4096 size 1.00GB
23:14:00,465 INFO program: Btrfs v0.20-rc1
23:14:00,466 DEBUG program: Return code: 0
23:14:00,480 INFO program: Running... udevadm settle --timeout=300
23:14:00,505 DEBUG program: Return code: 0
23:14:00,506 INFO program: Running... udevadm settle --timeout=300
23:14:00,516 DEBUG program: Return code: 0
23:14:00,518 INFO program: Running... udevadm settle --timeout=300
23:14:00,532 DEBUG program: Return code: 0
23:14:00,535 INFO program: Running... udevadm settle --timeout=300
23:14:00,545 DEBUG program: Return code: 0
23:14:00,550 INFO program: Running... mkfs.btrfs --label=f17 /dev/vda7
23:14:00,562 INFO program: /dev/vda7 appears to contain an existing filesystem (btrfs).
23:14:00,563 INFO program: Use the -f option to force overwrite.
23:14:00,563 INFO program:


Why does it invoke mkfs.btrfs twice?

The storage.log is here [3].


[1] http://fedoraproject.org/wiki/Anaconda/Kickstart#btrfs
[2] http://paste.fedoraproject.org/19514/37159847
[3] http://paste.fedoraproject.org/19515/37159861



Version-Release number of selected component (if applicable):

19.30.3-1


How reproducible:

Always


Steps to Reproduce:
1. Create a kickstart file with the above lines
2. Attempt to install (for example using virt-install)
3. 

Actual results:

Above

Expected results:

f19 installs with the btrfs volume created.


Additional info:
Comment 1 David Lehman 2013-06-19 08:54:38 EDT
Please try again with anaconda-19.30.6-1 or later. This looks like it could be caused by bug 966761. Please report back with your results.
Comment 2 Amit Saha 2013-06-19 19:53:20 EDT
(In reply to David Lehman from comment #1)
> Please try again with anaconda-19.30.6-1 or later. This looks like it could
> be caused by bug 966761. Please report back with your results.

Indeed. it does. Thanks. It works as expected now with the latest build from Koji.
Comment 3 Brian Lane 2013-06-20 21:34:32 EDT

*** This bug has been marked as a duplicate of bug 966761 ***

Note You need to log in before you can comment on or make changes to this bug.