Bug 975751 - configure both SPICE and VNC display console
configure both SPICE and VNC display console
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks: 976044
  Show dependency treegraph
 
Reported: 2013-06-19 05:27 EDT by Michal Skrivanek
Modified: 2013-11-21 04:03 EST (History)
10 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-22.el6
Doc Type: Bug Fix
Doc Text:
Cause: Due to loader HV versions, many features were available only for guests with only one display. Consequence: Guests with 2 displays couldn't be properly defined on QEMU hypervisor and some other features were not properly taking other than the first display into consideration. Fix: For new enough HV versions (those that support it), the ability to define more display types and all one-display assumptions were fixed in all relevant code. Result: Domains with multiple displays may now be defined, properly migrated, started and so on (with new enough hypervisor).
Story Points: ---
Clone Of:
: 976044 (view as bug list)
Environment:
Last Closed: 2013-11-21 04:03:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Skrivanek 2013-06-19 05:27:15 EDT
support configuration of both SPICE and VNC console at the same time. QEMU support is there since 0.10.0 and it's also fixed in upstream libvirt commit 37b415200.
Please backport to 6.5 so the feature can be added to RHEV-M
Comment 1 Michal Skrivanek 2013-06-19 05:28:27 EDT
as per conversation adding Martin
Comment 3 CongDong 2013-06-26 07:48:54 EDT
I'm confused with this bug, can you provide the steps to reproduce the problem please?
Comment 9 Martin Kletzander 2013-07-24 05:21:44 EDT
No it doesn't, going through the code there is something wrong.  I'm moving it to assigned and looking for a reason.
Comment 12 zhe peng 2013-08-15 01:15:41 EDT
verify with build:
libvirt-0.10.2-22.el6.x86_64

step:
1:config both spice and vnc in one guest at same time and start the guest
#virsh dumpxml $guest
 <graphics type='vnc' port='5900' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <graphics type='spice' port='5901' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>

2: use remote-viewer to connect the guest

#remote-viewer spice://127.0.0.1:5901
#remote-viewer vnc://127.0.0.1:5900
all can connect the console

3: check qemu cli:
#ps -ef | grep kvm
....
-vnc 0.0.0.0:0 -spice port=5901,addr=0.0.0.0,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864
....
verification passed.
Comment 14 errata-xmlrpc 2013-11-21 04:03:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1581.html

Note You need to log in before you can comment on or make changes to this bug.