Bug 976044 - [RFE] configure both SPICE and VNC display console
Summary: [RFE] configure both SPICE and VNC display console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: Shira Maximov
URL: http://www.ovirt.org/Features/Multipl...
Whiteboard:
: 949199 (view as bug list)
Depends On: 975751 1033547
Blocks: 1236497 1302542
TreeView+ depends on / blocked
 
Reported: 2013-06-19 19:46 UTC by Michal Skrivanek
Modified: 2016-03-09 20:31 UTC (History)
12 users (show)

Fixed In Version: ovirt-3-6-0-2
Doc Type: Enhancement
Doc Text:
This feature allows users to enable multiple console clients (for example, SPICE and VNC) for a virtual machine, so that users can switch clients without restarting the virtual machine. The virtual machine can now be configured with a "SPICE + VNC" console type, which enables this behavior. The "Console Options" dialog for a virtual machine enables protocols to be switched on a per-user basis.
Clone Of: 975751
: 1033547 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:31:35 UTC
oVirt Team: Virt
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
Red Hat Bugzilla 1236497 None None None Never

Internal Links: 1236497

Description Michal Skrivanek 2013-06-19 19:46:23 UTC
for related rhev-m side changes

+++ This bug was initially created as a clone of Bug #975751 +++

support configuration of both SPICE and VNC console at the same time. QEMU support is there since 0.10.0 and it's also fixed in upstream libvirt commit 37b415200.
Please backport to 6.5 so the feature can be added to RHEV-M

--- Additional comment from Michal Skrivanek on 2013-06-19 05:28:27 EDT ---

as per conversation adding Martin

Comment 1 Michal Skrivanek 2013-07-25 12:50:25 UTC
let's see if libvirt makes it to RHEL 6.5 and reconsider 3.3 then. Should not be difficult on RHEV-M side. Though I'm putting an emphasis on the word should:)

Comment 3 Michal Skrivanek 2013-12-02 15:42:43 UTC
*** Bug 949199 has been marked as a duplicate of this bug. ***

Comment 7 Michal Skrivanek 2015-01-12 12:05:52 UTC
done upstream

Comment 12 Shira Maximov 2015-10-20 07:31:58 UTC
verified on: 
Red Hat Enterprise Virtualization Manager Version: 3.6.0.1-0.1.el6

link to test run :
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3%5F6%5FVIRT%5Fconfigure%5Fboth%5FSPICE%5Fand%5FVNC%5F20%5F10&tab=records&result=passed

Comment 14 errata-xmlrpc 2016-03-09 20:31:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.