Bug 9758 - pcmcia rh61 boot disk makes TravelMate6030 freeze
pcmcia rh61 boot disk makes TravelMate6030 freeze
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 12296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 12:48 EST by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-15 11:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-02-24 12:48:26 EST
I have a Texas Instrument TravelMate 6030 which is working with kernel
2.0.33 and pcmcia 2.9.12.

I want to install rh61 on it (via network-pccard).

It completely locks up when booting with the rh61 pcmcia boot diskette
(from errata images), just when the screen shows "Initializing PC Card
Devices..."; it locks up with or without the network pccard inserted.
Another notebook, Acer Extensa 501T, goes on ok, with (beep beep) or
without (no beep) the network pccard inserted.
So the diskette is not broken, but it fails to recognize my TM6030.

Here are the kernel messages of the TM6030 when it succesfully boots
the "old" linux, from which you can see the pccard chip details:

kernel: Linux PCMCIA Card Services 2.9.12
kernel:   Kernel build: 2.0.33 #1 Tue Jan 6 19:28:29 MST 1998
kernel: Intel PCIC probe:
kernel:   TI 1130 CardBus at 0x3e0 ofs 0x00, mem 0x68000000, 2 sockets
kernel:     host opts:  [isa irq]
kernel:     irq list (scanned) = 5,7,9,10,11,12,15 status change on irq 15
cardmgr[131]: starting, version is 2.9.12
cardmgr[131]: watching 2 sockets
kernel: cs: IO port probe 0x0100-0x03ff: excluding 0x220-0x22f 0x300-0x307
0x388-0x38f
kernel: cs: IO port probe 0x0a20-0x0a27: clean.
cardmgr[131]: initializing socket 1
kernel: cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xcffff
0xe0000-0xfffff
cardmgr[131]: socket 1: RPTI EP401 Ethernet Card
cardmgr[131]: executing: 'insmod /lib/modules/2.0.33/net/8390.o'
cardmgr[131]: executing: 'insmod /lib/modules/2.0.33/pcmcia/pcnet_cs.o'
kernel: loading device 'eth0'...
kernel: eth0: NE2000 Compatible: port 0x320, irq 5, hw_addr
00:40:95:40:25:48
cardmgr[131]: executing: './network start eth0'

If there are just some settings to change in /etc/pcmcia, please tell me;
I'll try to install rh61 in another way, but when installed I'll need it
to recognize the network pc-card.

Thanks.
Comment 1 giulioo 2000-05-09 05:13:59 EDT
The same problem exists with rh62 pcmcia boot disk.
Comment 2 Doug Ledford 2000-05-09 23:32:59 EDT
You need to boot the machine up with a 6.2 pcmcia boot disk and as soon as the
system will allow you, switch to VT4 (by pressing ALT-F4) and see what messages
come out of the system prior to the lockup.  Copy those down and paste them here
so we can see them.
Comment 3 giulioo 2000-05-10 03:55:59 EDT
Here they are, it seems they don't show any error though:

<4>VFS: Mounted Root (ext2 filesystem)
<6> Linux PCMCIA Card Services 3.1.8
<6>   kernel build: 2.2.14-5.0BOOT #1 Tue Mar 7 20:31:32 EST 2000
<6>   options: [pci] [cardbus]
<6> Intel PCIC probe:
<6>   TI 1130 PCI-to-CardBus at bus 0 slot 1, mem 0x68000000, 2 sockets
<6>     host opts [0]: [isa irq] [no pci irq] [lat 168/176] [bus 32/34]
<6>     host opts [1]: [isa irq] [no pci irq] [lat 168/176] [bus 35/37]
<6>     ISA irqs (default) = 5,7,9,10,11,12,15 polling interval = 1000 ms
<30>May 10 09:33:40 cardmgr[14]: starting, version is 3.1.8
<30>May 10 09:33:40 cardmgr[14]: watching 2 sockets

Nothing more, the notebook is freezed now.

Thanks.
Comment 4 Michael Fulbright 2000-06-15 11:26:25 EDT
*** Bug 12296 has been marked as a duplicate of this bug. ***
Comment 5 giulioo 2000-07-21 17:12:09 EDT
Closed, see #12296 for info.

Note You need to log in before you can comment on or make changes to this bug.