Bug 975813 - fedup f18 -> f19 grub2 theme files not found
fedup f18 -> f19 grub2 theme files not found
Status: CLOSED DUPLICATE of bug 975800
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 08:05 EDT by Peter Kotvan
Modified: 2013-06-24 10:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:47:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Kotvan 2013-06-19 08:05:30 EDT
Description of problem:
I performed upgrade with fedup from f18 to f19. After upgrade grub reports following error before showing boot menu:

error: file `/grub2/themes/system/DejaVu-Sans-10.pf2' not found.
error: file `/grub2/themes/system/DejaVu-Sans-12.pf2' not found.
error: file `/grub2/themes/system/DejaVu-Sans-Bold-14.pf2' not found.
error: file `/grub2/themes/system/theme.txt' not found.
Press any key to continue...

After that plain grub menu appears. Actual booting works fine.

Version-Release number of selected component (if applicable):
f18 to f19-TC5
grub2-15.fc18 in f18 and grub2-20.fc19 in f19

Steps to Reproduce:
1. install fedora 18 desktop from install DVD
2. yum update; reboot
3. fedup with --instrepo https://dl.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/
4. reboot

Actual results:
When booting error message appears reporting that some of grub2 theme files are missing, user is prompted to press any key. After that plain grub2 menu appears.

Expected results:
Fancy grub2 menu.
Comment 1 Peter Kotvan 2013-06-20 05:27:43 EDT
The same behavior appeared when upgrading f18 to f19-TC6.
Comment 2 Will Woods 2013-06-20 13:24:30 EDT
All fedup does is install packages; if grub2 needs to migrate/modify config files to make the menu work, that's something to fix in the grub2 package.
Comment 3 pizza306 2013-06-20 15:57:51 EDT
same things happened here, too.
not upgrade from F18, using F19-beta for daily-use already.
after update grub2 and grub2-tools from 2.00-19 to 2.00-20 would appeared same behavior.
Comment 4 Will Woods 2013-06-24 10:47:55 EDT

*** This bug has been marked as a duplicate of bug 975800 ***

Note You need to log in before you can comment on or make changes to this bug.