Bug 975800 - Theme error after upgrading to latest grub2
Theme error after upgrading to latest grub2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 975813 977962 (view as bug list)
Depends On: 962004 974667
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 07:33 EDT by Stephen Gallagher
Modified: 2013-07-02 23:29 EDT (History)
13 users (show)

See Also:
Fixed In Version: grub2-2.00-23.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 23:29:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Photo of grub error (757.56 KB, image/jpeg)
2013-06-19 07:33 EDT, Stephen Gallagher
no flags Details

  None (edit)
Description Stephen Gallagher 2013-06-19 07:33:46 EDT
Created attachment 762879 [details]
Photo of grub error

Description of problem:
After upgrading to the latest grub2 package in the stable repository, I now experience an error loading theme files in GRUB2 (see attached photo). Setting urgency to low because the system *does* continue to boot after this.

Version-Release number of selected component (if applicable):
grub2-2.00-20.fc19.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Reboot computer

Actual results:
Error messages appear for several seconds before timing out and presenting the text-based GRUB2 screen

Expected results:
No error messages expected. Ideally, GRUB2 should continue using the theme that was in use prior to upgrade.

Additional info:
I upgraded from grub2-2.00-18.fc19.x86_64
Comment 1 Adam Williamson 2013-06-19 11:31:25 EDT
This is well known, and there really isn't much we can practically speaking do about it. (c) 2013 pjones
Comment 2 Adam Williamson 2013-06-21 15:26:27 EDT
actually, -21 should address this to some degree, so setting ON_QA. I think it will only work for 'fresh' updates from F18 to F19, though, if you already went through -19 and/or -20, I think you're stuffed unless you manually install grub2-starfield-theme .

Thu Jun 20 2013 Peter Jones <pjones@redhat.com> - 2.00-21 - Fix obsoletes to pull in -starfield-theme subpackage when it should.
Comment 3 Will Woods 2013-06-24 10:47:55 EDT
*** Bug 975813 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2013-06-26 15:07:32 EDT
On a clean F18 -> F19 fedup using F19 Final RC2 upgrade.img and repos, I didn't get grub2-starfield-theme , just grub2-2.00-22.fc19.x86_64 . Not sure why not.
Comment 5 Kalev Lember 2013-06-30 06:58:41 EDT
Looks like it's missing epoch in the newly added obsoletes.

Obsoletes:	grub2 <= 2.00-20%{?dist}

Should instead be:

Obsoletes:	grub2 < 1:2.00-21
Comment 6 mwp.junk 2013-07-01 22:00:06 EDT
I had this problem as well, but I worked around it by modifying /etc/default/grub with the following change:

-GRUB_THEME="/boot/grub2/themes/system/theme.txt"
+GRUB_THEME="/boot/grub2/themes/starfield/theme.txt"

then issuing: sudo grub2-mkconfig -o /boot/grub2/grub.cfg

What's interesting is that the Starfield theme is the default grub 2 theme and not a Fedora theme. The Fedora 19 release notes mention the grub 2 theme was changed to promote a more seamless boot experience. So, did the Fedora 19 release intend to remove all theme support? Because, the old F18 grub 2 theme was removed during fedUp, but nothing was put in its place.
Comment 7 Adam Williamson 2013-07-02 00:38:41 EDT
That applies to fresh installs of F19, not upgrades.

Fresh installs of F19 do not get a graphically themed grub at all, they get a console mode grub. We don't tinker with grub2.cfg on upgrade, though, so upgraded systems keep whatever was the default from the Fedora release they started out as.

grub2-starfield-theme is intended to be installed on upgrades to F19, but due to the bug mentioned in comment #5, that is not currently happening.

Thanks, Kalev - setting back to ASSIGNED for pjones to correct the issue. Or I may do it, since I hear he's on vacation.
Comment 8 Kamil Páral 2013-07-02 04:28:41 EDT
*** Bug 977962 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-07-02 14:41:10 EDT
grub2-2.00-23.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/grub2-2.00-23.fc19
Comment 10 Fedora Update System 2013-07-02 23:29:24 EDT
grub2-2.00-23.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.