Bug 975835 - [RFE] Foreign Menu Using REST
Summary: [RFE] Foreign Menu Using REST
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Christophe Fergeau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
: 739523 1188214 (view as bug list)
Depends On: 975834 1123771 1127156 1181289
Blocks: 1188212 1200067
TreeView+ depends on / blocked
 
Reported: 2013-06-19 12:33 UTC by Tomas Jelinek
Modified: 2016-03-09 20:03 UTC (History)
13 users (show)

Fixed In Version: mingw-libgovirt-0.3.3-1.el7ev mingw-spice-gtk-0.26-4.el7ev mingw-virt-viewer-2.0-2.el7ev rhevm-spice-client 3.6-2
Doc Type: Enhancement
Doc Text:
Using the remote-viewer tool to connect to an ovirt:// URI now displays a menu that allows the user to change the CD image inserted in the virtual machine (VM). This makes it possible to change the inserted CD while the VM is running without the need to use Red Hat Enterprise Virtualization or the oVirt portal.
Clone Of: 975834
: 1200067 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:03:58 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0377 0 normal SHIPPED_LIVE rhevm-spice-client bug fix and enhancement update 2016-03-10 00:39:05 UTC

Description Tomas Jelinek 2013-06-19 12:33:58 UTC
+++ This bug was initially created as a clone of Bug #975834 +++

Create a client for the oVirt's REST API for requesting foreign menu (similar to dynamicMenu but using REST API).

For more information about the specific details please see the oVirt's feature page:
http://www.ovirt.org/Features/Foreign_Menu_Using_REST

Comment 1 Tomas Jelinek 2013-06-27 12:13:57 UTC
The nature of this RFE has been changed - originally the client should have parsed a menu provided by oVirt REST. This is not true anymore. The new description is:
Client should be able to get the list of available CD images and also perform the change CD using the oVirt REST. oVirt will provide the sessionId to authenticate with the REST and the vmGuid in the .vv file.

Comment 2 Marc-Andre Lureau 2015-02-02 12:08:24 UTC
*** Bug 1188214 has been marked as a duplicate of this bug. ***

Comment 3 Christophe Fergeau 2015-06-04 12:29:21 UTC
Foreign menu support is available in the version mingw-virt-viewer is being rebased to. Need to make sure mingw-libgovirt is present in the BuildRequires.

Comment 4 Christophe Fergeau 2015-06-04 15:28:05 UTC
*** Bug 739523 has been marked as a duplicate of this bug. ***

Comment 5 Uri Lublin 2015-06-15 23:23:07 UTC
Rebase done, built packages:
 mingw-libgovirt-0.3.3-1.el7ev
 mingw-spice-gtk-0.26-4.el7ev
 mingw-virt-viewer-2.0-2.el7ev
 rhevm-spice-client 3.6-2

Comment 9 errata-xmlrpc 2016-03-09 20:03:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0377.html


Note You need to log in before you can comment on or make changes to this bug.