Bug 976204 - spice-server crash on booting off F19 final TC5 netinst iso
spice-server crash on booting off F19 final TC5 netinst iso
Status: CLOSED DUPLICATE of bug 952666
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 02:29 EDT by Amit Shah
Modified: 2013-06-20 03:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 03:33:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2013-06-20 02:29:21 EDT
Description of problem:

Grab the iso from

https://alt.fedoraproject.org/pub/alt/stage/19-TC5/Fedora/x86_64/iso/

Start qemu with the following arguments.

/usr/libexec/qemu-kvm -m 1G -smp 2 -cpu host,+x2apic -cdrom Fedora-19-TC5-x86_64-netinst.iso -net user -net nic,model=virtio -drive if=none,file=/guests/F19.qcow2,cache=unsafe,id=dr0 -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=dr0,bus=scsi0.0 -vnc :2 -vga qxl

After selecting the first option (install), or letting the timeout expire, this error is spewed:

SpiceWorker-CRITICAL **: red_worker.c:9324:red_create_surface: Untested path stride >= 0

$ rpm -q qemu-kvm spice-server
qemu-kvm-0.12.1.2-2.361.el6_4.bz909059.v9.x86_64
spice-server-0.12.0-12.el6_4.1.x86_64


(gdb) run
Starting program: /usr/libexec/qemu-kvm -m 1G -smp 2 -cpu host,+x2apic -cdrom Fedora-19-TC5-x86_64-netinst.iso -net user -net nic,model=virtio -drive if=none,file=/guests/F19.qcow2,cache=unsafe,id=dr0 -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=dr0,bus=scsi0.0 -vnc :2 -vga qxl
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff0037700 (LWP 8356)]
[New Thread 0x7fffef435700 (LWP 8357)]
[New Thread 0x7fffeea34700 (LWP 8358)]
[New Thread 0x7fffe7bf1700 (LWP 8365)]
[Thread 0x7ffff0037700 (LWP 8356) exited]
[New Thread 0x7ffff0037700 (LWP 8374)]
(/usr/bin/gdb:8352): SpiceWorker-CRITICAL **: red_worker.c:9324:red_create_surface: Untested path stride >= 0
Detaching after fork from child process 8375.

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fffe7bf1700 (LWP 8365)]
0x00007ffff57208a5 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.0.22-3.el6.x86_64 celt051-0.5.1.3-0.el6.x86_64 cyrus-sasl-gssapi-2.1.23-13.el6_3.1.x86_64 cyrus-sasl-lib-2.1.23-13.el6_3.1.x86_64 cyrus-sasl-md5-2.1.23-13.el6_3.1.x86_64 cyrus-sasl-plain-2.1.23-13.el6_3.1.x86_64 db4-4.7.25-17.el6.x86_64 dbus-libs-1.2.24-7.el6_3.x86_64 flac-1.2.1-6.1.el6.x86_64 glib2-2.26.0-3.el6.x86_64 glibc-2.12-1.107.el6.x86_64 gnutls-2.8.5-10.el6_4.2.x86_64 keyutils-libs-1.4-4.el6.x86_64 krb5-libs-1.10.3-10.el6_4.3.x86_64 libICE-1.0.6-1.el6.x86_64 libSM-1.2.1-2.el6.x86_64 libX11-1.5.0-4.el6.x86_64 libXau-1.0.6-4.el6.x86_64 libXext-1.3.1-2.el6.x86_64 libXi-1.6.1-3.el6.x86_64 libXtst-1.2.1-2.el6.x86_64 libaio-0.3.107-10.el6.x86_64 libasyncns-0.8-1.1.el6.x86_64 libcom_err-1.41.12-14.el6.x86_64 libgcrypt-1.4.5-9.el6_2.2.x86_64 libgpg-error-1.7-4.el6.x86_64 libjpeg-turbo-1.2.1-1.el6.x86_64 libogg-1.1.4-2.1.el6.x86_64 libselinux-2.0.94-5.3.el6_4.1.x86_64 libsndfile-1.0.20-5.el6.x86_64 libtasn1-2.3-3.el6_2.1.x86_64 libuuid-2.17.2-12.9.el6_4.3.x86_64 libvorbis-1.2.3-4.el6_2.1.x86_64 libxcb-1.8.1-1.el6.x86_64 nss-softokn-freebl-3.12.9-11.el6.x86_64 openssl-1.0.0-27.el6_4.2.x86_64 pixman-0.26.2-5.el6_4.x86_64 pulseaudio-libs-0.9.21-14.el6_3.x86_64 tcp_wrappers-libs-7.6-57.el6.x86_64 usbredir-0.5.1-1.el6.x86_64 zlib-1.2.3-29.el6.x86_64
(gdb) t a a bt

Thread 6 (Thread 0x7ffff0037700 (LWP 8374)):
#0  0x00007ffff773b7bb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffff7e1fdd7 in cond_timedwait (unused=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/posix-aio-compat.c:102
#2  aio_thread (unused=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/posix-aio-compat.c:329
#3  0x00007ffff7737851 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ffff57d690d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fffe7bf1700 (LWP 8365)):
#0  0x00007ffff57208a5 in raise () from /lib64/libc.so.6
#1  0x00007ffff5722085 in abort () from /lib64/libc.so.6
#2  0x00007ffff5f7ad45 in spice_logv (log_domain=0x7ffff5ff6f9e "SpiceWorker", log_level=SPICE_LOG_LEVEL_CRITICAL, 
    strloc=0x7ffff5ff837e "red_worker.c:9324", function=0x7ffff5ff9780 "red_create_surface", format=
    0x7ffff5ff8364 "Untested path stride >= 0", args=0x7fffe7bf0950) at log.c:109
#3  0x00007ffff5f7ae7a in spice_log (log_domain=<value optimized out>, log_level=<value optimized out>, 
    strloc=<value optimized out>, function=<value optimized out>, format=<value optimized out>) at log.c:123
#4  0x00007ffff5f4bdeb in red_create_surface (worker=0x7fff900008c0, surface_id=<value optimized out>, surface=...)
    at red_worker.c:9324
#5  dev_create_primary_surface (worker=0x7fff900008c0, surface_id=<value optimized out>, surface=...)
    at red_worker.c:11059
#6  0x00007ffff5f4c343 in handle_dev_create_primary_surface_async (opaque=<value optimized out>, 
    payload=<value optimized out>) at red_worker.c:11293
#7  0x00007ffff5f38d37 in dispatcher_handle_single_read (dispatcher=0x7ffff888fd18) at dispatcher.c:139
#8  dispatcher_handle_recv_read (dispatcher=0x7ffff888fd18) at dispatcher.c:162
#9  0x00007ffff5f591be in red_worker_main (arg=<value optimized out>) at red_worker.c:11883
#10 0x00007ffff7737851 in start_thread () from /lib64/libpthread.so.0
#11 0x00007ffff57d690d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fffeea34700 (LWP 8358)):
#0  0x00007ffff57cea47 in ioctl () from /lib64/libc.so.6
#1  0x00007ffff7e01f3a in kvm_run (env=0x7ffff8864010) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1015
#2  0x00007ffff7e023e9 in kvm_cpu_exec (env=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1743
#3  0x00007ffff7e032cd in kvm_main_loop_cpu (_env=0x7ffff8864010)
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2004
#4  ap_main_loop (_env=0x7ffff8864010) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2060
#5  0x00007ffff7737851 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ffff57d690d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fffef435700 (LWP 8357)):
---Type <return> to continue, or q <return> to quit---
#0  0x00007ffff57cea47 in ioctl () from /lib64/libc.so.6
#1  0x00007ffff7e01f3a in kvm_run (env=0x7ffff884a8f0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1015
#2  0x00007ffff7e023e9 in kvm_cpu_exec (env=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1743
#3  0x00007ffff7e032cd in kvm_main_loop_cpu (_env=0x7ffff884a8f0)
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2004
#4  ap_main_loop (_env=0x7ffff884a8f0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2060
#5  0x00007ffff7737851 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ffff57d690d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ffff7d46980 (LWP 8352)):
#0  0x00007ffff57cf4f3 in select () from /lib64/libc.so.6
#1  0x00007ffff7dddb08 in main_loop_wait (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4007
#2  0x00007ffff7e0048a in kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2244
#3  0x00007ffff7de0a18 in main_loop (argc=23, argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4227
#4  main (argc=23, argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6570
Comment 2 Christophe Fergeau 2013-06-20 03:33:23 EDT

*** This bug has been marked as a duplicate of bug 952666 ***

Note You need to log in before you can comment on or make changes to this bug.