Bug 976217 - xfs_repair: handle fragmented multiblock dir2 directories
xfs_repair: handle fragmented multiblock dir2 directories
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsprogs (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Eric Sandeen
Boris Ranto
: ZStream
Depends On: 964216
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 03:08 EDT by Jan Kurik
Modified: 2013-06-27 09:12 EDT (History)
12 users (show)

See Also:
Fixed In Version: xfsprogs-3.1.1-10.el6_4.1
Doc Type: Bug Fix
Doc Text:
Previously, xfs_repair was unable to properly handle fragmented multiblock version 2 directories (Multiblock dir2 is only enabled with the "-n size=" mkfs.xfs option, where the size is greater than the file system block size). With this update, xfs_repair can operate on fragmented dir2 directories without errors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 09:12:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0987 normal SHIPPED_LIVE xfsprogs bug fix update 2013-06-27 13:01:11 EDT

  None (edit)
Description Jan Kurik 2013-06-20 03:08:04 EDT
This bug has been copied from bug #964216 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 4 Eric Sandeen 2013-06-20 13:41:47 EDT
Built in xfsprogs-3.1.1-10.el6_4.1
Comment 9 errata-xmlrpc 2013-06-27 09:12:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0987.html

Note You need to log in before you can comment on or make changes to this bug.