Bug 976229 - Moodle does not work because missing DHTMLRulesTableless.php
Moodle does not work because missing DHTMLRulesTableless.php
Status: CLOSED DUPLICATE of bug 947252
Product: Fedora EPEL
Classification: Fedora
Component: moodle (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 03:28 EDT by Milan Kerslager
Modified: 2013-07-12 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 11:39:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2013-06-20 03:28:30 EDT
Package moodle-2.2.10-1.el6.noarch links to external PEAR library, but external PEAR-HTML library is not complete (as Moodle requires).

My Moodle upgraded installation shows empty page because DHTMLRulesTableless.php is not found in the system. There is few symlinks in /var/www/moodle/web/lib/pear/HTML:

 Common.php -> /usr/share/pear/HTML/Common.php
 QuickForm -> /usr/share/pear/HTML/QuickForm
 QuickForm.php -> /usr/share/pear/HTML/QuickForm.php

In original package, there is file DHTMLRulesTableless.php in moodle/lib/pear/HTML/QuickForm, but in EPEL repository, there is no DHTMLRulesTableless.php file in actual EPEL package(s):

# yum whatprovides \*/DHTMLRulesTableless.php
Loaded plugins: downloadonly, fastestmirror, presto
Loading mirror speeds from cached hostfile
 * base: ftp.cvut.cz
 * epel: mirror.1000mbps.com
 * extras: ftp.cvut.cz
 * updates: ftp.cvut.cz
No Matches found

Bacause dependency is not met, Moodle does not work. I did not tested empty Moodle, but this does not matter.

This package should not rely on php-pear-HTML-QuickForm-3.2.12-1.el6.noarch package until full requirements are met.

I reported this for moodle-2.2.9 before (IIRC).
Comment 1 Jon Ciesla 2013-07-12 11:39:29 EDT

*** This bug has been marked as a duplicate of bug 947252 ***

Note You need to log in before you can comment on or make changes to this bug.