Bug 976460 - [RFE] Support access via ip address
Summary: [RFE] Support access via ip address
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Katello QA List
URL:
Whiteboard:
: 996684 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-20 15:36 UTC by Justin Sherrill
Modified: 2019-09-26 13:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 18:39:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Sherrill 2013-06-20 15:36:39 UTC
Description of problem:

Currently Signo requires the user to access Satellite 6 via FQDN only, and only the FQDN that the certs were generated with at install time.  


In a production deployment this is not that big of a deal, but for developers, especially ones that are using vms to spin up preinstalled katello/satellite instances this is a huge pain.

For example, I typically have vm's that all use the same fake hostname (katello.devel).  I can spin them up with a version of katello already installed. So i may have 5 or 10 vms all with the same hostname of katello.devel. Now with signo i have to modify my /etc/hosts file between access to every one.  Previously i could just go back and forth between the ip addresses of the different katello instances.

Comment 1 RHEL Program Management 2013-06-20 16:05:05 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Marek Hulan 2013-06-28 08:48:35 UTC
It should work as long as your virtuals can resolve their hostnames locally. Also note that if you have problems with certificate you can set verify_certificate to false in signo configuration.

Comment 6 Mike McCune 2013-10-17 21:01:33 UTC
Moving this to be tested during MDP3, not critical for MDP2 success story

Comment 7 Mike McCune 2014-01-16 21:17:00 UTC
removing signo component and moving these bugs to 'Infrastructure'

Comment 10 Mike McCune 2014-05-05 18:19:52 UTC
*** Bug 996684 has been marked as a duplicate of this bug. ***

Comment 11 Corey Welton 2014-05-08 00:36:11 UTC
Moving to 6.0.4 for QE purposes.


Note You need to log in before you can comment on or make changes to this bug.