Bug 996684 - Accessing Satellite 6 without FQDN causes rewrite loops
Accessing Satellite 6 without FQDN causes rewrite loops
Status: CLOSED DUPLICATE of bug 976460
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 13:16 EDT by Mike McCune
Modified: 2014-06-19 15:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 14:19:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-08-13 13:16:13 EDT
Attempt to login via IP address or a short hostname in the webui and you will get stuck in a rewrite loop:

"The page isn't redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete."


Steps to reproduce:

1) Browse to the IP of your Satellite 6 host:

https://<ip address>/katello

2) note error

If we are going to redirect we should support it properly such that if the user enters a short hostname or IP we should send them to the correct location without error.
Comment 1 RHEL Product and Program Management 2013-09-17 00:18:51 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Bryan Kearney 2014-01-13 10:10:39 EST
signo is removed in Sat6 MDP3, so moving this to POST. It should no longer be an issue.
Comment 6 Mike McCune 2014-01-16 16:16:49 EST
removing signo component and moving these bugs to 'Infrastructure'
Comment 9 Mike McCune 2014-05-05 14:19:52 EDT

*** This bug has been marked as a duplicate of bug 976460 ***

Note You need to log in before you can comment on or make changes to this bug.