Bug 976551 - No check for already enabled collections in scl enable <collection>+ <command>
No check for already enabled collections in scl enable <collection>+ <command>
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scl-utils (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jan Zeleny
Lukas Zachar
: ZStream
Depends On: 964058
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 14:57 EDT by Jan Kurik
Modified: 2013-07-16 05:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: scl-utils-20120927-2.el6_4.6
Doc Type: Bug Fix
Doc Text:
* Previously, when enabling collections, a check whether a collection was enabled was performed. However, independently of the result the collection was always enabled. Consequently, if a single collection had been stated multiple times in the command line, it would be enabled multiple times. In the case of some destructive enable scriptlets, this might have led to some undetermined behavior. This update runs the enable scriptlet only if the collection has not been enabled before, and attempts to enable a collection multiple times in one environment will be ignored.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 05:53:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-06-20 14:57:55 EDT
This bug has been copied from bug #964058 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 errata-xmlrpc 2013-07-16 05:53:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1065.html

Note You need to log in before you can comment on or make changes to this bug.