Bug 976790 - rhqctl upgrade with migrator doesn't work
rhqctl upgrade with migrator doesn't work
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-06-21 09:15 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhqctl_upgrade_oracle.log (66.13 KB, text/x-log)
2013-07-02 13:13 EDT, Armine Hovsepyan
no flags Details
rhqctl_upgrade_postgres.log (65.68 KB, text/x-log)
2013-07-02 13:14 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-06-21 09:15:56 EDT
Description of problem:
rhqctl upgrade with migrator doesn't work

Version-Release number of selected component (if applicable):
build e008c08

How reproducible:
always

Steps to Reproduce:
1. install rhq server 4.5.1
2. run ./rhq-server-4.8.0-SNAPSHOT/bin/rhqctl upgrade --from-server-dir /home/hudson/rhq-server-4.5.1 --run-data-migrator do-it
3.

Actual results:
postgres -> http://d.pr/f/Kvkf
oralce -> http://d.pr/f/Aswx

Expected results:
postgres- > migration works with default parameters
oracle -> config params used in rhq-data-migrator.sh should be acceptable for upgrade and migrator should work

Additional info:
Comment 1 Stefan Negrea 2013-06-28 16:36:22 EDT
Updated the code to use the connection url from rhq-server.properties. For oracle the code should not rely in individual properties to generate a connection url since a lot of the properties are marked with "unused" in the configuration file.

Also updated the code to use the rhq-server.properties file implicitly.


Please retest.
Comment 2 Armine Hovsepyan 2013-07-01 07:09:46 EDT
ClassCastException while running upgrade with migration without params and with 
param estimate -> http://d.pr/f/rtG4

version: 2390  jenkins master build
Comment 3 Stefan Negrea 2013-07-01 10:15:20 EDT
Update the code one more time. The Cassandra driver had a different expectation for the seed list argument. Please retest.
Comment 4 Armine Hovsepyan 2013-07-02 13:12:57 EDT
checked for both postgres and oracle migration with upgrade.
please get attached logs of verification.

thank you.
Comment 5 Armine Hovsepyan 2013-07-02 13:13:39 EDT
Created attachment 767883 [details]
rhqctl_upgrade_oracle.log
Comment 6 Armine Hovsepyan 2013-07-02 13:14:01 EDT
Created attachment 767884 [details]
rhqctl_upgrade_postgres.log

Note You need to log in before you can comment on or make changes to this bug.