Bug 976867 - subscription-manager autoheal needs feedback and a review of options
subscription-manager autoheal needs feedback and a review of options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-21 13:23 EDT by John Sefler
Modified: 2013-09-30 19:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:11:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GUI feedback for new auto-heal function (29.39 KB, image/png)
2013-06-21 13:31 EDT, John Sefler
no flags Details
VERIFIED GUI Prefernce dialog has been re-arranged (21.19 KB, image/png)
2013-07-17 12:25 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2013-06-21 13:23:37 EDT
Description of problem:
This bug contains some initial issues about the new CLI autoheal module. 

Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.11-1.git.13.96b613e.el5


Steps to Reproduce:

ISSUE 0:
NEEDINFO from mreid - should autoheal be hyphenated to auto-heal?  I think yes simply to be consistent with auto-attach.


ISSUE 1:
[root@jsefler-5 ~]# subscription-manager autoheal --help
Usage: subscription-manager autoheal [OPTIONS]

Manage the autoheal setting for this system

options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --username=USERNAME   username to use when authorizing against the server
  --password=PASSWORD   password to use when authorizing against the server
  --org=ORG_KEY         specify whether to enable or disable autohealing of
                        subscriptions
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:443/prefix
  --insecure            do not check the server SSL certificate against
                        available certificate authorities
  --enable              enable autohealing of subscriptions
  --disable             disable autohealing of subscriptions
[root@jsefler-5 ~]# 

Several of the options listed above seem unnecessary for the auto-heal use case.
I think these options are unnecessary:
--username
--password
--org
--serverurl
--insecure

Instead, I believe the options for auto-heal module should be:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --show                shows current auto-heal setting; default command   <======= NOTICE THIS
  --enable              enable auto-healing of subscriptions <====== NOTICE HYPHENATIONS
  --disable             disable auto-healing of subscriptions


ISSUE 2:
[root@jsefler-5 ~]# subscription-manager clean
All local data removed
[root@jsefler-5 ~]# subscription-manager autoheal
Error: you must register or specify --username and --password to list service levels
[root@jsefler-5 ~]# 

Expected: 
This system is not yet registered. Try 'subscription-manager register --help' for more information.


ISSUE 3:
[root@jsefler-5 ~]# subscription-manager register
Username: testuser1
Password: 
Organization: admin
The system has been registered with ID: f10f5620-1410-4a00-bbe2-18b450f0d1c8 
[root@jsefler-5 ~]# subscription-manager autoheal    (OR subscription-manager auto-heal --show)
[root@jsefler-5 ~]# 

Expected Stdout: Auto-heal is currently enabled


ISSUE 4:
[root@jsefler-5 ~]# subscription-manager autoheal --disable
[root@jsefler-5 ~]# 

Expected Stdout: Auto-heal is disabled


ISSUE 5:
[root@jsefler-5 ~]# subscription-manager autoheal --enable
[root@jsefler-5 ~]# 

Expected Stdout: Auto-heal is enabled
Comment 1 John Sefler 2013-06-21 13:31:36 EDT
Created attachment 763914 [details]
GUI feedback for new auto-heal function

ISSUE 6:
NEEDINFO from mreid for attached screenshot...
A. How about moving this setting first in the dialog to keep the checkbox versus drop-down list preferences together.
B. I understand that this is an Auto-attach preference, but to provide parity with the CLI, it is really an Auto-heal preference.  The description could and probably should include the auto-attach term.
C. Can you line up the checkbox horizontally with the title just like the drop down lists?  This will provide needed real-estate for translated descriptions.
Comment 2 RHEL Product and Program Management 2013-06-21 13:47:35 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Cory Scheviak 2013-07-11 15:01:04 EDT
43845092ef68f249f400e15c17a099d8d9221631
Comment 4 John Sefler 2013-07-17 12:21:01 EDT
Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager subscription-manager-gui
subscription-manager-1.8.13-1.el5
subscription-manager-gui-1.8.13-1.el5


(In reply to John Sefler from comment #0)
> ISSUE 0:

[root@jsefler-5 ~]# subscription-manager --help | grep auto
  auto-attach    Set if this system runs auto-attach each check-in

VERIFIED: autoheal was renamed to auto-attach


> ISSUE 1:
[root@jsefler-5 ~]# subscription-manager auto-attach --help
Usage: subscription-manager auto-attach [OPTIONS]

Set if this system runs auto-attach each check-in

options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --enable              try to attach subscriptions for uncovered products
                        each check-in
  --disable             do not try to automatically attach subscriptions each
                        check-in
  --show                show the current auto-attach preference

VERIFIED: offending options have been removed


> ISSUE 2:
[root@jsefler-5 ~]# subscription-manager clean
All local data removed
[root@jsefler-5 ~]# subscription-manager auto-attach
This system is not yet registered. Try 'subscription-manager register --help' for more information.

VERIFIED


> ISSUE 3:
[root@jsefler-5 ~]# subscription-manager register --username testuser1 --org admin
Password: 
The system has been registered with ID: 41940d9c-9b49-4868-9bb7-4923a1a95e46 
[root@jsefler-5 ~]# subscription-manager auto-attach --show
Auto-attach preference: enabled
[root@jsefler-5 ~]# subscription-manager auto-attach
Auto-attach preference: enabled

VERIFIED: feedback preference is displayed


> ISSUE 4:
[root@jsefler-5 ~]# subscription-manager auto-attach --disable
Auto-attach preference: disabled
[root@jsefler-5 ~]# subscription-manager auto-attach
Auto-attach preference: disabled

VERIFIED: feedback preference is displayed


> ISSUE 5:
[root@jsefler-5 ~]# subscription-manager auto-attach --enable
Auto-attach preference: enabled
[root@jsefler-5 ~]# subscription-manager auto-attach
Auto-attach preference: enabled

VERIFIED: feedback preference is displayed
Comment 5 John Sefler 2013-07-17 12:25:52 EDT
Created attachment 774849 [details]
VERIFIED GUI Prefernce dialog has been re-arranged
Comment 7 errata-xmlrpc 2013-09-30 19:11:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.