Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 976897 - Excessive Heap Consumption in com.sun.imageio.plugins.jpeg.JPEGImageWriter
Summary: Excessive Heap Consumption in com.sun.imageio.plugins.jpeg.JPEGImageWriter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukáš Zachar
URL:
Whiteboard:
Depends On:
Blocks: 992910
TreeView+ depends on / blocked
 
Reported: 2013-06-21 19:45 UTC by Ricardo Martinelli de Oliveira
Modified: 2018-12-04 15:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1025555 (view as bug list)
Environment:
Last Closed: 2013-11-22 00:25:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Test Case (1.39 KB, text/x-java)
2013-06-21 19:45 UTC, Ricardo Martinelli de Oliveira
no flags Details
Java 7 compatible test-case (2.48 KB, text/x-java)
2013-07-02 18:32 UTC, Adam Domurad
no flags Details
Candidate fix (986 bytes, patch)
2013-07-02 18:37 UTC, Adam Domurad
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1741 0 normal SHIPPED_LIVE java-1.6.0-openjdk bug fix and enhancement update 2013-11-20 22:04:14 UTC
Sun Bug Database 8020983 0 None None None Never

Description Ricardo Martinelli de Oliveira 2013-06-21 19:45:59 UTC
Created attachment 763948 [details]
Test Case

Description of problem:
After upgrading to java-1.6.0-openjdk-1.6.0.0-1.61.1.11.11.el6_4.x86_64, Java applications are consuming more memory (specifically int[] objects allocated by com.sun.imageio.plugins.jpeg.JPEGImageWriter), without releasing it.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-1.61.1.11.11.el6_4.x86_64

How reproducible:
Easily reprocible with a test case.

Steps to Reproduce:
1. Compile and run Prueba.java (attached in bz)
2. Use the following VM parameter: -Xmx64m 
3. Use the following Program Parameter: 1000

Actual results:
It throws a OOME Heap Size Exception

Expected results:
Allocate objects and print memory information

Additional info:

Comment 4 Adam Domurad 2013-07-02 18:32:27 UTC
Created attachment 767894 [details]
Java 7 compatible test-case

Comment 5 Adam Domurad 2013-07-02 18:37:02 UTC
Created attachment 767905 [details]
Candidate fix

Comment 13 Mario Torre 2013-07-31 09:19:51 UTC
Fix has been committed upstream in the 8 branch:

http://hg.openjdk.java.net/jdk8/2d/jdk/rev/7f0e569c5a66

I'll ask the backport on 6 and 7 now.

Cheers,
Mario

Comment 15 Mario Torre 2013-08-05 09:46:07 UTC
The fix has been backported to 7, I'm awaiting the backport to 6 now.

Comment 16 Mario Torre 2013-08-26 16:31:39 UTC
I have backported the patch for 6 myself, here is the RFC:

http://mail.openjdk.java.net/pipermail/jdk6-dev/2013-August/003033.html

And here the patch:

http://cr.openjdk.java.net/~neugens/8020983/webrev/

Waiting for reviewer's approval now.

Comment 17 jiri vanek 2013-08-27 16:03:16 UTC
The fix is in 8 and 7, and is going to 6. I will include the patch to RPMs directly to speed up escalation.

Comment 20 errata-xmlrpc 2013-11-22 00:25:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1741.html

Comment 21 Aaron Ogburn 2013-12-12 19:10:17 UTC
Note this leak also impacted RHEL 5's open jdk (java-1.6.0-openjdk-1.6.0.0-1.41.1.11.11.90.el5_9) but appears to have been fixed as well (java-1.6.0-openjdk-1.6.0.0-1.42.1.11.14.el5_10)


Note You need to log in before you can comment on or make changes to this bug.