Bug 976924 - list --consumed should not substitute "None" for null support level and type
list --consumed should not substitute "None" for null support level and type
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
: Regression
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-21 18:13 EDT by John Sefler
Modified: 2014-09-14 20:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:11:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-06-21 18:13:01 EDT
Description of problem:
Bug 842170 has re-surfaced.  "None" should not be substituted for the absence of a service level or type.


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.15-1
subscription-manager: 1.8.11-1.git.13.96b613e.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-5 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS for x86_64
SKU:               awesomeos-x86_64
Pool ID:           8a90f8203f678a61013f678bcb500592
Quantity:          5
Service Level:                            <========= NOTICE NO SERVICE LEVEL
Service Type:                             <========= NOTICE NO SERVICE TYPE 
Multi-Entitlement: Yes
Ends:              06/20/2014
System Type:       Physical

[root@jsefler-5 ~]# subscription-manager subscribe --pool 8a90f8203f678a61013f678bcb500592
Successfully attached a subscription for: Awesome OS for x86_64
[root@jsefler-5 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS for x86_64
Provides:          Awesome OS for x86_64 Bits
SKU:               awesomeos-x86_64
Contract:          78
Account:           12331131231
Serial:            2298634082312824120
Pool ID:           8a90f8203f678a61013f678bcb500592
Active:            True
Quantity Used:     1
Service Level:     None                    <========= EXPECTED NO VALUE
Service Type:      None                    <========= EXPECTED NO VALUE
Status Details:    Only covers 1 of 2 sockets.
Starts:            06/20/2013
Ends:              06/20/2014
Comment 1 RHEL Product and Program Management 2013-06-21 18:17:19 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Carter Kozak 2013-06-24 09:33:13 EDT
Looks like something went wrong in a merge, fix is on the way
Comment 4 Carter Kozak 2013-06-26 10:16:02 EDT
commit 77aace5566184f0032e9ec28353c29e7088aa60d
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jun 24 09:30:32 2013 -0400

    976924: empty service level and type
Comment 7 Shwetha Kallesh 2013-07-15 02:42:10 EDT
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.16-1
subscription-manager: 1.8.13-1.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5


[root@localhost ~]# subscription-manager register --org=admin --force 
The system with UUID 9b66ccd2-50d1-4b04-861e-a8f5ac328cf5 has been unregistered
Username: admin
Password: 
The system has been registered with ID: e88ab74a-147d-4c70-8fee-1ee270c8ce0f 
[root@localhost ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS for x86_64
SKU:               awesomeos-x86_64
Pool ID:           8ac6a3a23fbcb162013fbcb26d7f06ea
Quantity:          4
Service Level:     
Service Type:      
Multi-Entitlement: Yes
Ends:              07/08/2014
System Type:       Physical




[root@localhost ~]# subscription-manager attach --pool 8ac6a3a23fbcb162013fbcb26d7f06ea
Successfully attached a subscription for: Awesome OS for x86_64

[root@localhost ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS for x86_64
Provides:          Awesome OS for x86_64 Bits
SKU:               awesomeos-x86_64
Contract:          78
Account:           12331131231
Serial:            7837040159205657709
Pool ID:           8ac6a3a23fbcb162013fbcb26d7f06ea
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    Only covers 1 of 4 sockets.
Starts:            07/08/2013
Ends:              07/08/2014
Comment 9 errata-xmlrpc 2013-09-30 19:11:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.