Bug 97705 - please add a "pdf printer"
please add a "pdf printer"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: desktop-printing (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
David Lawrence
: FutureFeature
: 109849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 11:14 EDT by matteo porta
Modified: 2007-04-18 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 11:26:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matteo porta 2003-06-19 11:14:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
I've tried without success to add a "pdf printer" using cups (i'm talking about
a virtual printer that creates pdf files).
I've seen that kde has by default a pdf printer, so please add one for gnome too.
Thanks.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. n/a
2.
3.
    

Additional info:
Comment 1 Tim Waugh 2003-06-19 12:36:47 EDT
Need more information about what behaviour is needed.  For instance, what should
happen to PDFs that get created?
Comment 2 matteo porta 2003-06-19 14:12:55 EDT
after the print command from an application the pdf writer virtual printer
should open a file requester, asking the name of the pdf file to be created.
this is the normal behaviour under windows (if you install programs like
fineprint pdf factory) and many users are expecting that it works this way
(which is quite intuitive, imho).
thanks.

Comment 3 Tim Waugh 2003-06-19 15:34:16 EDT
That's not something you want on the CUPS server end then.
Comment 4 Tim Waugh 2003-11-12 07:47:46 EST
*** Bug 109849 has been marked as a duplicate of this bug. ***
Comment 5 Aaron Schlaegel 2004-04-29 02:27:59 EDT
I think this is a great feature to have.

Since an interactive GUI might not be easy/possible, I recommend
saving the pdf files in the home directory.

The basic concept is similar to the printer tray. When you print to a
physical printer, pages stack up in the tray. When you print to
virtual pdf printer, files sequence in your home directory.

I would extend this concept to allow filename configuration via the
printer configuration.
PDF file name:
[] date
[] time
[] application
Comment 6 Colin Walters 2004-12-16 11:26:42 EST
At least FC3 includes "Create a PDF document" in the print dialog, and
the filename can be chosen via the "Location" option.  Seems
sufficient to me.

Note You need to log in before you can comment on or make changes to this bug.