Bug 977053 - [abrt] WARNING: at drivers/net/wireless/iwlegacy/common.c:3118 il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]()
[abrt] WARNING: at drivers/net/wireless/iwlegacy/common.c:3118 il_enqueue_hcm...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:14b7fb5d1fca92a5b446c904bc5...
:
: 980287 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 19:07 EDT by Justin Pearce
Modified: 2013-08-10 16:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.10.4-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 13:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (82.91 KB, text/plain)
2013-06-22 19:07 EDT, Justin Pearce
no flags Details
iwl4965_reset_on_rfkill.patch (1.19 KB, text/plain)
2013-07-05 09:15 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Justin Pearce 2013-06-22 19:07:11 EDT
Additional info:
reporter:       libreport-2.1.4
WARNING: at drivers/net/wireless/iwlegacy/common.c:3118 il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]()
Hardware name: HP Compaq 6910p (GV630UC#ABA)
Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 bnep iptable_nat nf_nat_ipv4 nf_nat bluetooth iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables acpi_cpufreq mperf coretemp kvm_intel kvm arc4 snd_hda_codec_analog iwl4965 snd_hda_intel ppdev microcode iwlegacy mac80211 snd_hda_codec snd_hwdep snd_seq snd_seq_device cfg80211 snd_pcm snd_page_alloc snd_timer snd soundcore hp_wmi sparse_keymap iTCO_wdt iTCO_vendor_support rfkill irda crc_ccitt serio_raw hp_accel parport_pc e1000e ptp parport pps_core lis3lv02d input_polldev lpc_ich mfd_core mei uinput dm_crypt pata_pcmcia sdhci_pci sdhci mmc_core i915 firewire_ohci firewire_core crc_itu_t yenta_socket i2c_algo_bit ata_generic drm_kms_helper drm pata_acpi i2c_core wmi video
Pid: 769, comm: wpa_supplicant Not tainted 3.9.6-200.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105efca>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa045f248>] il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]
 [<ffffffffa045f59a>] il_send_cmd_sync+0x12a/0x4f0 [iwlegacy]
 [<ffffffff810977cf>] ? __dequeue_entity+0x2f/0x50
 [<ffffffffa048019c>] il4965_request_scan+0xa9c/0xb60 [iwl4965]
 [<ffffffff8109bf44>] ? enqueue_entity+0x384/0x970
 [<ffffffffa045cf44>] il_mac_hw_scan+0x3a4/0x410 [iwlegacy]
 [<ffffffffa03a8170>] __ieee80211_start_scan+0x1a0/0x5a0 [mac80211]
 [<ffffffff81187e28>] ? __kmalloc+0x208/0x250
 [<ffffffffa03a9029>] ieee80211_request_scan+0x39/0x60 [mac80211]
 [<ffffffffa03b5f89>] ieee80211_scan+0x89/0x90 [mac80211]
 [<ffffffffa02d6a32>] nl80211_trigger_scan+0x682/0x710 [cfg80211]
 [<ffffffff8157fbd0>] genl_rcv_msg+0x250/0x2d0
 [<ffffffff8157f980>] ? genl_rcv+0x40/0x40
 [<ffffffff8157f571>] netlink_rcv_skb+0xb1/0xc0
 [<ffffffff8157f965>] genl_rcv+0x25/0x40
 [<ffffffff8157ee91>] netlink_unicast+0x1a1/0x220
 [<ffffffff8157f211>] netlink_sendmsg+0x301/0x3c0
 [<ffffffff8153a450>] sock_sendmsg+0xb0/0xe0
 [<ffffffff811b2640>] ? __pollwait+0xf0/0xf0
 [<ffffffff8153be5c>] __sys_sendmsg+0x3ac/0x3c0
 [<ffffffff811b343d>] ? core_sys_select+0x26d/0x320
 [<ffffffff811dfb1b>] ? fsnotify+0x24b/0x340
 [<ffffffff810b190c>] ? ktime_get_ts+0x4c/0xf0
 [<ffffffff811b2805>] ? poll_select_copy_remaining+0xf5/0x150
 [<ffffffff8153de29>] sys_sendmsg+0x49/0x90
 [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
Comment 1 Justin Pearce 2013-06-22 19:07:18 EDT
Created attachment 764208 [details]
File: dmesg
Comment 2 Justin Pearce 2013-06-23 18:11:30 EDT
Description of problem:
Trying to enable both wifi and bluetooth on P 6910p laptop.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.4
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.6-200.fc18.x86_64 root=/dev/mapper/fedora_isa-root ro rd.lvm.lv=fedora_isa/swap rd.md=0 rd.dm=0 vconsole.keymap=us rd.luks.uuid=luks-d9086af1-30ab-4942-b0a1-e0b58b4db43e rd.lvm.lv=fedora_isa/root rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/net/wireless/iwlegacy/common.c:3118 il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]()
Hardware name: HP Compaq 6910p (GV630UC#ABA)
Modules linked in: btusb bnep bluetooth ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables arc4 snd_hda_codec_analog snd_hda_intel snd_hda_codec iwl4965 iwlegacy iTCO_wdt mac80211 snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc cfg80211 snd_timer iTCO_vendor_support irda snd soundcore crc_ccitt acpi_cpufreq mperf coretemp kvm_intel kvm hp_wmi sparse_keymap rfkill ppdev microcode serio_raw lpc_ich mfd_core e1000e ptp pps_core mei parport_pc parport hp_accel lis3lv02d input_polldev uinput binfmt_misc dm_crypt pata_pcmcia sdhci_pci sdhci firewire_ohci i915 mmc_core firewire_core crc_itu_t yenta_socket i2c_algo_bit drm_kms_helper drm ata_generic i2c_core pata_acpi wmi video
Pid: 868, comm: wpa_supplicant Not tainted 3.9.6-200.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105efca>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa04c4248>] il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]
 [<ffffffffa04c459a>] il_send_cmd_sync+0x12a/0x4f0 [iwlegacy]
 [<ffffffff810977cf>] ? __dequeue_entity+0x2f/0x50
 [<ffffffffa04e519c>] il4965_request_scan+0xa9c/0xb60 [iwl4965]
 [<ffffffffa04c1f44>] il_mac_hw_scan+0x3a4/0x410 [iwlegacy]
 [<ffffffffa042f170>] __ieee80211_start_scan+0x1a0/0x5a0 [mac80211]
 [<ffffffff81187e28>] ? __kmalloc+0x208/0x250
 [<ffffffffa0430029>] ieee80211_request_scan+0x39/0x60 [mac80211]
 [<ffffffffa043cf89>] ieee80211_scan+0x89/0x90 [mac80211]
 [<ffffffffa03c1a32>] nl80211_trigger_scan+0x682/0x710 [cfg80211]
 [<ffffffff8157fbd0>] genl_rcv_msg+0x250/0x2d0
 [<ffffffff8157f980>] ? genl_rcv+0x40/0x40
 [<ffffffff8157f571>] netlink_rcv_skb+0xb1/0xc0
 [<ffffffff8157f965>] genl_rcv+0x25/0x40
 [<ffffffff8157ee91>] netlink_unicast+0x1a1/0x220
 [<ffffffff8157f211>] netlink_sendmsg+0x301/0x3c0
 [<ffffffff8153a450>] sock_sendmsg+0xb0/0xe0
 [<ffffffff811b2640>] ? __pollwait+0xf0/0xf0
 [<ffffffff8153be5c>] __sys_sendmsg+0x3ac/0x3c0
 [<ffffffff811b343d>] ? core_sys_select+0x26d/0x320
 [<ffffffff811dfb1b>] ? fsnotify+0x24b/0x340
 [<ffffffff810b190c>] ? ktime_get_ts+0x4c/0xf0
 [<ffffffff811b2805>] ? poll_select_copy_remaining+0xf5/0x150
 [<ffffffff8153de29>] sys_sendmsg+0x49/0x90
 [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
Comment 3 Justin Pearce 2013-06-24 12:18:22 EDT
Description of problem:
Booting to Fedora on dual boot HP/Compaq 6910p laptop with wireless adapter enabled.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.4
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.6-200.fc18.x86_64 root=/dev/mapper/fedora_isa-root ro rd.lvm.lv=fedora_isa/swap rd.md=0 rd.dm=0 vconsole.keymap=us rd.luks.uuid=luks-d9086af1-30ab-4942-b0a1-e0b58b4db43e rd.lvm.lv=fedora_isa/root rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/net/wireless/iwlegacy/common.c:3118 il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]()
Hardware name: HP Compaq 6910p (GV630UC#ABA)
Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables bnep snd_hda_codec_analog arc4 snd_hda_intel snd_hda_codec iwl4965 iwlegacy mac80211 iTCO_wdt iTCO_vendor_support serio_raw ppdev cfg80211 btusb hp_wmi sparse_keymap bluetooth rfkill snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc acpi_cpufreq mperf coretemp kvm_intel snd_timer kvm snd microcode soundcore irda crc_ccitt lpc_ich mfd_core e1000e ptp pps_core mei parport_pc parport hp_accel lis3lv02d input_polldev uinput binfmt_misc dm_crypt pata_pcmcia firewire_ohci sdhci_pci sdhci mmc_core i915 firewire_core crc_itu_t yenta_socket i2c_algo_bit drm_kms_helper drm ata_generic i2c_core pata_acpi wmi video
Pid: 778, comm: wpa_supplicant Not tainted 3.9.6-200.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105efca>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa0544248>] il_enqueue_hcmd+0x578/0x5a0 [iwlegacy]
 [<ffffffffa054459a>] il_send_cmd_sync+0x12a/0x4f0 [iwlegacy]
 [<ffffffff8109a089>] ? update_curr+0x99/0x170
 [<ffffffffa056d19c>] il4965_request_scan+0xa9c/0xb60 [iwl4965]
 [<ffffffff8109bf44>] ? enqueue_entity+0x384/0x970
 [<ffffffffa0541f44>] il_mac_hw_scan+0x3a4/0x410 [iwlegacy]
 [<ffffffffa048d170>] __ieee80211_start_scan+0x1a0/0x5a0 [mac80211]
 [<ffffffff81187e28>] ? __kmalloc+0x208/0x250
 [<ffffffffa048e029>] ieee80211_request_scan+0x39/0x60 [mac80211]
 [<ffffffffa049af89>] ieee80211_scan+0x89/0x90 [mac80211]
 [<ffffffffa041fa32>] nl80211_trigger_scan+0x682/0x710 [cfg80211]
 [<ffffffff8157fbd0>] genl_rcv_msg+0x250/0x2d0
 [<ffffffff8157f980>] ? genl_rcv+0x40/0x40
 [<ffffffff8157f571>] netlink_rcv_skb+0xb1/0xc0
 [<ffffffff8157f965>] genl_rcv+0x25/0x40
 [<ffffffff8157ee91>] netlink_unicast+0x1a1/0x220
 [<ffffffff8157f211>] netlink_sendmsg+0x301/0x3c0
 [<ffffffff8153a450>] sock_sendmsg+0xb0/0xe0
 [<ffffffff811b2640>] ? __pollwait+0xf0/0xf0
 [<ffffffff8153be5c>] __sys_sendmsg+0x3ac/0x3c0
 [<ffffffff811b343d>] ? core_sys_select+0x26d/0x320
 [<ffffffff811dfb1b>] ? fsnotify+0x24b/0x340
 [<ffffffff810977cf>] ? __dequeue_entity+0x2f/0x50
 [<ffffffff810b190c>] ? ktime_get_ts+0x4c/0xf0
 [<ffffffff811b2805>] ? poll_select_copy_remaining+0xf5/0x150
 [<ffffffff8153de29>] sys_sendmsg+0x49/0x90
 [<ffffffff8166a5d9>] system_call_fastpath+0x16/0x1b
Comment 4 Stanislaw Gruszka 2013-07-05 09:03:48 EDT
*** Bug 980287 has been marked as a duplicate of this bug. ***
Comment 5 Stanislaw Gruszka 2013-07-05 09:15:38 EDT
Created attachment 769241 [details]
iwl4965_reset_on_rfkill.patch

Proposed patch. Problems seems to be caused by firmware instability, which somehow is not able to work properly after RFKILL on/off. This patch reset device after we enable radio, what hopefully should make problems gone. 

Kernel build with the patch is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5576337
Please test (when it finish to compile).
Comment 6 Stanislaw Gruszka 2013-07-08 03:18:19 EDT
Waiting for test results ...
Comment 7 Justin Pearce 2013-07-10 20:04:21 EDT
(In reply to Stanislaw Gruszka from comment #6)
> Waiting for test results ...

Initial testing seems to indicate that the patch seems to repair the issue with the hardware failing to initialize properly. Looks like it works.
Comment 8 Stanislaw Gruszka 2013-08-01 06:17:02 EDT
Patch posted:
http://marc.info/?l=linux-wireless&m=137535149932248&w=2

Josh, please apply it as fix for this bug.
Comment 9 Josh Boyer 2013-08-01 08:45:30 EDT
Applied to F18-rawhide.  Thanks!
Comment 10 Fedora Update System 2013-08-02 17:47:24 EDT
kernel-3.10.4-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.10.4-100.fc18
Comment 11 Fedora Update System 2013-08-03 19:57:32 EDT
Package kernel-3.10.4-100.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.10.4-100.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14177/kernel-3.10.4-100.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-08-07 16:47:47 EDT
kernel-3.10.5-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.10.5-201.fc19
Comment 13 Fedora Update System 2013-08-09 13:12:16 EDT
kernel-3.10.5-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-08-10 16:10:13 EDT
kernel-3.10.4-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.