Bug 977321 - Wrong subscribe status with 'subscription-manager attach --auto' option
Wrong subscribe status with 'subscription-manager attach --auto' option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
: Regression
: 980748 (view as bug list)
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-24 06:15 EDT by Rehana
Modified: 2014-09-14 20:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 09:47:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2013-06-24 06:15:04 EDT
Description of problem:
Observed that the installed product status was not getting updated when executed subscription-manager attach --auto

Version-Release number of selected component (if applicable):
[root@localhost product]# rpm -qa | grep subscr
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-gui-1.8.11-1.git.13.96b613e.el5
subscription-manager-debuginfo-1.8.11-1.el5_9
subscription-manager-1.8.11-1.git.13.96b613e.el5
subscription-manager-migration-1.8.11-1.git.13.96b613e.el5
subscription-manager-firstboot-1.8.11-1.git.13.96b613e.el5
[root@localhost product]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.15-1
subscription-manager: 1.8.11-1.git.13.96b613e.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5


How reproducible:
3/3

Steps to Reproduce:
1.Register client to candlepin
2.Execute subscription-manager attach --auto

Actual results:
Observed that the output of attach --auto command is 

[root@localhost product]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: RAM Limiting Product
Status:       Not Subscribed

Product Name: Multi-Attribute Limited Product
Status:       Not Subscribed

Product Name: Awesome OS Developer Basic
Status:       Not Subscribed

Product Name: Awesome OS for All Arch (all per arch content) Bits
Status:       Not Subscribed

Product Name: Awesome OS Server Bits
Status:       Not Subscribed

consumed --list

[root@localhost product]# subscription-manager list --consumed

Subscription Name: RAM Limiting Package (4GB stackable)
Provides:          RAM Limiting Product
SKU:               ram-4gb-stackable
Contract:          174
Account:           12331131231
Serial:            6198993483096318911
Pool ID:           8ac6a3f83f74a7c3013f74a8c08c05ea
Active:            True
Quantity Used:     3
Service Level:     None
Service Type:      None
Status Details:    
Starts:            06/24/2013
Ends:              06/24/2014

Subscription Name: Awesome OS for All Arch (all per arch content)
Provides:          Awesome OS for All Arch (all per arch content) Bits
SKU:               awesomeos-per-arch-cont
Contract:          91
Account:           12331131231
Serial:            3705921523773022290
Pool ID:           8ac6a3f83f74a7c3013f74a8c5850773
Active:            True
Quantity Used:     10
Service Level:     None
Service Type:      None
Status Details:    
Starts:            06/24/2013
Ends:              06/24/2014

Subscription Name: Multi-Attribute Stackable (2 sockets)
Provides:          Multi-Attribute Limited Product
SKU:               sock2-multiattr
Contract:          205
Account:           12331131231
Serial:            5024077641895889053
Pool ID:           8ac6a3f83f74a7c3013f74a8bef0054f
Active:            True
Quantity Used:     8
Service Level:     Premium
Service Type:      Level 3
Status Details:    
Starts:            06/24/2013
Ends:              06/24/2014


Expected results:
root@localhost product]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: RAM Limiting Product
Status:       Not Subscribed <-- should be changed to "Subscribed"

Product Name: Multi-Attribute Limited Product
Status:       Not Subscribed <-- should be changed to "Subscribed"

Product Name: Awesome OS Developer Basic
Status:       Not Subscribed

Product Name: Awesome OS for All Arch (all per arch content) Bits
Status:       Not Subscribed <-- should be changed to "Subscribed"

Additional info:
Observed that the product status was getting updated when executed 
subscription-manager register --auto-attach
Comment 2 Carter Kozak 2013-07-03 09:38:22 EDT
*** Bug 980748 has been marked as a duplicate of this bug. ***
Comment 3 Carter Kozak 2013-07-03 11:25:34 EDT
commit f4d1a199631acf0d819e163c610cc751a37e4d61
Author: ckozak <ckozak@redhat.com>
Date:   Tue Jun 25 17:01:40 2013 -0400

    977851: 977321: Centralize CertSorter, drive updates, refresh properly
Comment 5 Rehana 2013-07-15 08:47:35 EDT
Retested,

[root@localhost rhsm]# subscription-manager register
Username: admin
Password: 
Organization: admin
The system has been registered with ID: f8f8fdbe-cad0-4fa2-938d-f12109a4a3f8 
[root@localhost rhsm]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Awesome OS for x86_64 Bits
Status:       Subscribed

Product Name: Awesome OS Server Bits
Status:       Subscribed

Product Name: Management Bits
Status:       Subscribed

Product Name: Large File Support Bits
Status:       Subscribed

Product Name: Awesome OS Modifier Bits
Status:       Subscribed

Product Name: Clustering Bits
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Product Name: Awesome OS Instance Server Bits
Status:       Subscribed

Product Name: Shared Storage Bits
Status:       Subscribed

Product Name: Load Balancing Bits
Status:       Subscribed

Product Name: Awesome OS Premium Architecture Bits
Status:       Not Subscribed

Observed that "--auto-attach" option updated the installed product status correctly.

hence moving the BZ to "Verified"

on 
rpm  -qa | grep subs
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-firstboot-1.8.13-1.el5_9
subscription-manager-debuginfo-1.8.13-1.el5_9
subscription-manager-1.8.13-1.el5_9
subscription-manager-migration-1.8.13-1.el5_9
subscription-manager-gui-1.8.13-1.el5_9

Note You need to log in before you can comment on or make changes to this bug.