Bug 97743 - Random hangs when mounting smb shares using fstab entries (esp. netfs)
Random hangs when mounting smb shares using fstab entries (esp. netfs)
Status: CLOSED DUPLICATE of bug 90036
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
:
: 103200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 21:26 EDT by Target
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Target 2003-06-19 21:26:20 EDT
Description of problem:

The process of mounting smb shares randomly hangs at random when using the ftsab
entry (as netfs does on bootup). This pretty much brings the boot-up process to
a grinding halt about 3/5ths of the time on a machine with two smb mounts.

Mounting completely manually (eg: mount //someserv/mountname -t smbfs -o
credentials=/home/joe/.smbid,uid=joe,rw /home/joe/mountpoint) does not cause the
random hangs, however mounting with the aid of an fstab entry (mount
/home/joe/samba) does hang randomly. Ctrl-C must be pressed to get the command
line back, but the share _is_ mounted in spite of the hang and there's no actual
indication of error.

Bug 13862 from three years ago looks very similar, only the hang during boot
occurs at "Mounting SMB filesystems"

There are five machines in total. These (and only these) were freshly installed
with RH9 and fully updated. All five are exhibiting this problem. The machines
previously ran RH 8, and did not have have this trouble. They were fully updated
until the wipe & install session today. The machines also vary in hardware and
function, so no imaging or kickstart scripts were used in any of the installs.  
(FYI: The server is a gentoo box, and no other workstation is having trouble
like this)

Unfortunately, this means that any machines with several shares are essentially
un-bootable without a rescue disk as they will hang almost every time when
running the netfs initscript. Netfs runs even before sshd, so we can't even ssh
into the boxes and kill hung mount processes.

Version-Release number of selected component (if applicable):
samba: 2.2.7a-8.9.0
mount: 2.11y-9
initscripts: 7.14-1

How reproducible:
Very. I've found that the likelyhood of a hang running netfs is over 50% on a
machine with two smb mounts.

Steps to Reproduce:
1. Add several smb shares to fstab to be mounted on boot.
2. Reboot (or mount/umount the shares a few times using fstab's help).
3. Watch the mount process hang.
    
Actual results:

Mount hangs randomly while mounting fstab-aided smb shares.

Expected results:

No hangs one way or the other.

Additional info:

A messy and unpleasant workaround is to edit the netfs script and force it to
background the mounting tasks. It works, since even on a hang the filesystems do
get mounted- We just wind up with one or more mount processes sitting in the
process list until killed manually.
Comment 1 Paul Rensing 2003-07-07 15:23:54 EDT
Looks like a variant of my bug #89589.
Comment 2 Target 2003-07-07 16:27:01 EDT
This is definitely a dupe of Bug 89589
Comment 3 Douglas Furlong 2003-07-18 10:12:26 EDT
I am suffering the same issue as this user, however if I use the suggested
method of mounting compleately from the command line, I still suffer from random
hangs.

Not much of an addition, but it may help you narrow it down.

Doug
Comment 4 Pádraig Brady 2003-09-09 09:48:31 EDT
Also 103200 is a dupe and has a possible workaround
Comment 5 Jay Fenlason 2003-09-09 10:34:56 EDT
*** Bug 103200 has been marked as a duplicate of this bug. ***
Comment 6 Jay Fenlason 2003-09-09 10:49:56 EDT

*** This bug has been marked as a duplicate of 90036 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:56:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.