Bug 97744 - Balsa 2.0.11-2 spec file requires gnome-print instead of libgnomeprint plus proposed enhancement patches
Balsa 2.0.11-2 spec file requires gnome-print instead of libgnomeprint plus p...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: balsa (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-06-19 23:08 EDT by Chris Chabot
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 15:45:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change to configure.in to check for libgnomeprint-2.2 before 2.0 (739 bytes, patch)
2003-06-19 23:09 EDT, Chris Chabot
no flags Details | Diff
Spec file update for BuildRequires and inclusion of new patch (841 bytes, patch)
2003-06-19 23:09 EDT, Chris Chabot
no flags Details | Diff

  None (edit)
Description Chris Chabot 2003-06-19 23:08:14 EDT
The balsa 2.0.11-2 spec file (from public rawhide @ jun 18) requires
gnome-print-devel (a gnome-1.4 package) instead of libgnomeprint (gnome 2).

Ps, balsa supports both libgnomeprint and libgnomeprint-2.2; And by default it
will use libgnomeprint-2.0 instead of libgnomeprint-2.2 (see configure.in).

However since the libgnomeprint 2.0 is quickly becomming a 'legacy' lib, and 2.2
intergrates a lot better with cups & other new features (and ximian's gnome-cups
lib & apps which might be merged upstream) i would sugest patching it to check
for 2.2 before 2.0.

Attaching balsa-2.0.11-libgnomeprint22.patch as proposed solution. Also
attaching a patch for the balsa spec file to fix & intergrate patch.

If you would choose to not go for the libgnomeprint22, at least
gnome-print-devel should be replaced with libgnomeprint >= 1.106.0 in BuildRequires.
Comment 1 Chris Chabot 2003-06-19 23:09:05 EDT
Created attachment 92503 [details]
Change to configure.in to check for libgnomeprint-2.2 before 2.0
Comment 2 Chris Chabot 2003-06-19 23:09:58 EDT
Created attachment 92504 [details]
Spec file update for BuildRequires and inclusion of new patch
Comment 3 Bill Nottingham 2003-10-03 15:45:19 EDT
Fixed in 2.0.15-1.

Note You need to log in before you can comment on or make changes to this bug.