Bug 977452 - Doc suggest setting glance to the wrong tenant in glance-api.conf
Doc suggest setting glance to the wrong tenant in glance-api.conf
Status: CLOSED DUPLICATE of bug 965943
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-06-24 11:11 EDT by Attila Darazs
Modified: 2013-09-24 13:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 20-06-2013 16:46:44 Topic ID: 16014-460330 [Latest]
Last Closed: 2013-07-02 18:39:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2013-06-24 11:11:39 EDT
Title: Configuring the Use of the Identity Service

Describe the issue:
# openstack-config --set /etc/glance/glance-api.conf \      
   keystone_authtoken admin_tenant_name admin

This command uses 'admin' tenant in italic without any explanation.

Suggestions for improvement:
The admin_tenant_name should be either glance (suggested in the previous pages), or services (if one is using the common tenant for all services), but not admin. Or the italic 'admin' word should be explained.
Comment 1 Attila Darazs 2013-06-24 11:17:29 EDT
Same problem with the glance-registry.conf some lines lower.
Comment 3 Attila Darazs 2013-06-24 11:24:25 EDT
Also admin_user should be "glance", or explained that admin means "the user created for glance" and then it will be more evident what to write for both the user and the tenant.
Comment 4 Stephen Gordon 2013-06-24 16:32:07 EDT
Ensure the action taken here is consistent with the outcome of Bug # 965943.
Comment 6 Summer Long 2013-07-01 22:46:54 EDT
(Apologies for my spelling of your name, not sure what that's about.)
Comment 7 Summer Long 2013-07-02 18:39:32 EDT
From Attila: The usage of services tenant seems consistent now. Thanks.
QE will be checking on all the changes in 965943, so closing this as 'Duplicate'.

*** This bug has been marked as a duplicate of bug 965943 ***

Note You need to log in before you can comment on or make changes to this bug.