Bug 97746 - (IT:23105) up2date python error message
up2date python error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 97748 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-20 02:55 EDT by jike.zhou
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 16:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jike.zhou 2003-06-20 02:55:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The traceback below has occurred on two machines so far, at the end of the
package install when I ran up2date today (2003/06/19).
It appears that the proper changes were made to grub.conf.

Traceback (innermost last):
 File "/usr/share/rhn/up2date_client/gui.py", line 909, in
 doInstallation
    up2date.installBootLoader(kernelsToInstall)
   File "/usr/share/rhn/up2date_client/up2date.py", line 608, in
 installBootLoader
     __install_grub(kernelList)
   File "/usr/share/rhn/up2date_client/up2date.py", line 624, in
__install_grub
     ret  = grubcfg.installNewImages(kernelList,test=0)
 AttributeError: installNewImages



Version-Release number of selected component (if applicable):
kernel-2.4.9-e.25

How reproducible:
Always

Steps to Reproduce:
1.up2date -uf kernel
2.
3.
    

Additional info:
Comment 1 Arjan van de Ven 2003-06-20 03:25:01 EDT
*** Bug 97748 has been marked as a duplicate of this bug. ***
Comment 2 Alois Treindl 2003-06-20 14:18:05 EDT
I use lilo, and I get this bug with the python error message:
Traceback (innermost last):

>   File "/usr/share/rhn/up2date_client/gui.py", line 909, in
> doInstallation
>     up2date.installBootLoader(kernelsToInstall)
>   File "/usr/share/rhn/up2date_client/up2date.py", line 604, in
> installBootLoader
>     __install_lilo(kernelList)
>   File "/usr/share/rhn/up2date_client/up2date.py", line 619, in
> __install_lilo
>     ret = lilocfg.installNewImages(kernelList,test=0)
> AttributeError: installNewImages
> 
> 
on RH 2.1ES

It is probably related to the same grub problem.
Comment 3 Narsi Subramanian 2003-07-14 12:05:48 EDT
Any estimate on when the fix would be available. It was observed with non-kernal
package updates. 
Comment 4 Steve Conklin 2004-08-25 11:20:54 EDT
Did this make the U5 beta?

Note You need to log in before you can comment on or make changes to this bug.