Bug 977535 - 'ascii' codec can't encode character u'\xe9' in position 163: ordinal not in range(128)
'ascii' codec can't encode character u'\xe9' in position 163: ordinal not in ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-24 16:08 EDT by John Sefler
Modified: 2014-09-14 20:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:11:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-06-24 16:08:56 EDT
Description of problem:
This bug is really a continuation of bug 919584.
As described in https://bugzilla.redhat.com/show_bug.cgi?id=919584#c1 we have a situation where we have choosen to fix the lesser of two bugs.  While I agree with awood that the fix in bug 919584 solves the more serious bug, we are still left with a very likely user case that produces the less severe bug.  I am opening this bug for at least the purpose of documenting a known issue in the Release Notes (although a simultaneous fix for this bug and bug 919584 would be ideal)...

To re-create this bug, simply run subscription-manager in a language with utf-8 character translations and pipe the output through grep.


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.11-1.git.13.96b613e.el5


How reproducible:
most commonly reproduced in non-english locales

Steps to Reproduce:
With at least the RHEL product cert (69.pem) installed, run the following...
[root@jsefler-5 ~]# LANG=fr_FR.utf-8 subscription-manager list --installed | grep ID
'ascii' codec can't encode character u'\xe9' in position 163: ordinal not in range(128)



Actual results:
above

Expected results:
Expected the output from subscription-manager list --installed to successfully get processed by the grep subshell.


Additional info:
  Technically this bug is a duplicate of former bug 800323 which was fixed in subscription-manager-1.1 and is now broken in subscription-manager-1.8.
Comment 1 RHEL Product and Program Management 2013-06-24 16:27:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Carter Kozak 2013-07-02 13:00:59 EDT
commit d3b2a827e8db6e47ae298ce5cae8fbe55b690964
Author: ckozak <ckozak@redhat.com>
Date:   Tue Jul 2 11:14:14 2013 -0400

    977535: cli uses utf8 too
Comment 5 John Sefler 2013-07-16 18:20:50 EDT
Verifying Version....
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.13-1.el5

[root@jsefler-5 ~]# LANG=fr_FR.utf-8 subscription-manager list --installed | grep ID
ID du produit :     69
[root@jsefler-5 ~]# 


VERIFIED!  This bug has been fix and therefore requires no release note documentation.

Removing the Doc Text...
Setting requires_doc_text -
Comment 7 errata-xmlrpc 2013-09-30 19:11:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.