Bug 977708 - [WHQL][netkvm]Job named 1c_Mini6Send failed on win8-32 guest with BSOD
[WHQL][netkvm]Job named 1c_Mini6Send failed on win8-32 guest with BSOD
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
: 982149 1181249 (view as bug list)
Depends On:
Blocks: 1181249
  Show dependency treegraph
 
Reported: 2013-06-25 03:52 EDT by Min Deng
Modified: 2015-02-02 08:29 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 08:43:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-06-25 03:52:28 EDT
Description of problem:
Job named 1c_Mini6Send failed on win8-32 guest.

Version-Release number of selected component (if applicable):
build 65

How reproducible:


Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:22:47:15:23:42,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet2,mac=00:32:58:14:3c:20,bus=pci.0,addr=0x6 -uuid 3b278c23-cb8b-4ba1-93af-a8c4f9a24037 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-64-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win8-32-nic1-64-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
2.submit the job 


Actual results:
The job failed due to BSOD

Expected results:
The job can pass

Additional info:
Will upload dump files and analysis later
Comment 5 Yan Vugenfirer 2013-06-30 07:20:05 EDT
Thanks for the dumps!

But I think that we have at least another two bugs opened for minisend test. I propose to unite them and indicated effected guests.


Thanks,
Yan.
Comment 9 Dmitry Fleytman 2013-08-20 02:43:04 EDT
*** Bug 982149 has been marked as a duplicate of this bug. ***
Comment 10 Dmitry Fleytman 2013-08-20 02:45:00 EDT
The same BSOD happens on Windows Server 2012 guest with OVS networking.
Comment 13 Min Deng 2013-08-21 23:12:47 EDT
Hi Dmitry,

   QE re-tested the bug on build 67 and the job named 1c_Mini6Send passed.We change new image and qemu-kvm&kernel&seabios&vgabios&spice-server on host at time time.
********************************************************
kernel-2.6.32-413.el6.x86_64.rpm
kernel-firmware-2.6.32-413.el6.noarch.rpm
qemu-img-rhev-0.12.1.2-2.397.el6.x86_64.rpm
qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64.rpm
qemu-kvm-rhev-debuginfo-0.12.1.2-2.397.el6.x86_64.rpm
qemu-kvm-rhev-tools-0.12.1.2-2.397.el6.x86_64.rpm
seabios-0.6.1.2-28.el6.x86_64.rpm
spice-server-0.12.4-2.el6.x86_64.rpm
vgabios-0.6b-3.7.el6.noarch.rpm
*******************************************************
  Actually,the job passed three times.However,the guest got an BSOD at the second time but the job passed eventually.I meant it was shown as pass in HCK.
  From my perspective,maybe the BSOD occurred after the job finished so it didn't affect the result itself,but I'm not very sure.Re-run the job,it still can pass but the guest didn't get BSOD.
  I will upload the dump and hck to the bug after a while.Any issues please let me know.Thanks.

Best Regards,
Min
Comment 15 Mike Cao 2013-08-22 01:18:51 EDT
(In reply to dengmin from comment #13)
> Hi Dmitry,
> 
>    QE re-tested the bug on build 67 and the job named 1c_Mini6Send passed.We
> change new image and qemu-kvm&kernel&seabios&vgabios&spice-server on host at
> time time.
> ********************************************************
> kernel-2.6.32-413.el6.x86_64.rpm
> kernel-firmware-2.6.32-413.el6.noarch.rpm
> qemu-img-rhev-0.12.1.2-2.397.el6.x86_64.rpm
> qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64.rpm
> qemu-kvm-rhev-debuginfo-0.12.1.2-2.397.el6.x86_64.rpm
> qemu-kvm-rhev-tools-0.12.1.2-2.397.el6.x86_64.rpm
> seabios-0.6.1.2-28.el6.x86_64.rpm
> spice-server-0.12.4-2.el6.x86_64.rpm
> vgabios-0.6b-3.7.el6.noarch.rpm
> *******************************************************
>   Actually,the job passed three times.However,the guest got an BSOD at the
> second time but the job passed eventually.I meant it was shown as pass in
> HCK.
>   From my perspective,maybe the BSOD occurred after the job finished so it
> didn't affect the result itself,but I'm not very sure.Re-run the job,it
> still can pass but the guest didn't get BSOD.
>   I will upload the dump and hck to the bug after a while.Any issues please
> let me know.Thanks.
> 
> Best Regards,
> Min

Pls upload commandline next time ,and pls retest this issue with -cpu 8 -m 6G for SUT 

Mike
Comment 20 Dmitry Fleytman 2013-08-24 04:07:13 EDT
This is a Microsoft bug covered by manual errata 3162.
Comment 21 Mike Cao 2013-08-25 10:33:21 EDT
(In reply to Dmitry Fleytman from comment #20)
> This is a Microsoft bug covered by manual errata 3162.

Could you help to add a comments about MSFT Email on this errata in this bug ?
Comment 23 Yan Vugenfirer 2015-02-02 08:29:01 EST
*** Bug 1181249 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.