Bug 977786 - Packstack writes unsupported config (qpidd, fedora 19)
Packstack writes unsupported config (qpidd, fedora 19)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Fedora Extras Quality Assurance
:
: 981601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 06:33 EDT by Matthias Runge
Modified: 2013-08-22 20:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.27.dev672.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 20:29:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 36656 None None None Never

  None (edit)
Description Matthias Runge 2013-06-25 06:33:42 EDT
Description of problem:
Packstack writes the following line into /etc/qpidd.conf:
cluster-mechanism=DIGEST-MD5 ANONYMOUS

Which results in the following message
[Broker] critical Unexpected error: Error in configuration file /etc/qpidd.conf: Bad argument: |cluster-mechanism=DIGEST-MD5 ANONYMOUS|

Fedora 19 uses the following version of qpidd
rpm -q qpid-cpp-server
qpid-cpp-server-0.22-1.1.fc19.x86_64
Comment 1 Martin Magr 2013-06-25 06:58:08 EDT
Workaround could be "yum install qpidd-cluster".
Comment 2 Matthias Runge 2013-06-25 07:03:57 EDT
[root@turing ~]# yum install qpidd-cluster
Loaded plugins: langpacks
No package qpidd-cluster available.

You mean qpid-cpp-server-ha? I tried that, and it didn't help.
Comment 3 Sandro Mathys 2013-06-25 07:25:48 EDT
Figure Martin meant qpid-cpp-server-cluster with is available in EL but not in Fedora...

...that said, it's not being installed (by Packstack or whatever) on EL either, but I don't see any such error in my logs. Chances are, qpid in EL is just too old (0.14 vs 0.22 in Fedora) and that kind of error is not implemented there yet, though.
Comment 4 Martin Magr 2013-06-25 08:31:13 EDT
I just did a quick google-around and posted first solution which looks  reasonable, but didn't check package availability. So Sandro is right it supposed to be qpid-cpp-server-cluster.

With version qpid-cpp-0.16-1.2 qpid-cpp-server-cluster subpackage is removed, so this is not valid anymore.
Comment 5 Martin Magr 2013-06-25 08:54:01 EDT
It looks like newer versions renamed configuration option to sasl-mechanism, can you try if it will help?
Comment 6 Martin Magr 2013-06-25 09:35:59 EDT
Hmm and in version from Fedora18 it is (you need qpid-cpp-server-ha installed):

"--ha-mechanism MECH   Authentication mechanism for connections between HA brokers"
Comment 7 Martin Magr 2013-06-25 10:37:57 EDT
Fixed upstream: https://github.com/derekhiggins/puppet-qpid/pull/1
Comment 8 Martin Magr 2013-07-08 05:58:26 EDT
*** Bug 981601 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-07-25 03:19:52 EDT
openstack-packstack-2013.1.1-0.21.dev651.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.21.dev651.fc19
Comment 10 Fedora Update System 2013-07-25 20:31:59 EDT
Package openstack-packstack-2013.1.1-0.21.dev651.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-packstack-2013.1.1-0.21.dev651.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13636/openstack-packstack-2013.1.1-0.21.dev651.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-08-01 06:52:05 EDT
openstack-packstack-2013.1.1-0.22.dev653.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.22.dev653.fc19
Comment 12 Fedora Update System 2013-08-02 17:58:11 EDT
Package openstack-packstack-2013.1.1-0.22.dev653.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-packstack-2013.1.1-0.22.dev653.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14101/openstack-packstack-2013.1.1-0.22.dev653.fc19
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-08-09 03:08:04 EDT
openstack-packstack-2013.1.1-0.23.dev657.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.23.dev657.fc19
Comment 14 Fedora Update System 2013-08-13 13:38:59 EDT
openstack-packstack-2013.1.1-0.24.dev660.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.24.dev660.fc19
Comment 15 Fedora Update System 2013-08-19 12:24:24 EDT
openstack-packstack-2013.1.1-0.25.dev672.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.25.dev672.fc19
Comment 16 Fedora Update System 2013-08-19 12:34:50 EDT
openstack-packstack-2013.1.1-0.26.dev672.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.26.dev672.fc19
Comment 17 Fedora Update System 2013-08-19 12:48:17 EDT
openstack-packstack-2013.1.1-0.27.dev672.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-packstack-2013.1.1-0.27.dev672.fc19
Comment 18 Fedora Update System 2013-08-22 20:29:59 EDT
openstack-packstack-2013.1.1-0.27.dev672.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.