Bug 97781 - 'service apmd restart' succeeds everytime
'service apmd restart' succeeds everytime
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: apmd (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-20 17:48 EDT by Enrico Scholz
Modified: 2015-01-07 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.0.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 17:10:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-06-20 17:48:28 EDT
Description of problem:

The return value of 'service apmd restart' should reflect errors, but:

| # mv /usr/sbin/apmd{,_}    # Create error-condition
| # service apmd restart
| Shutting down APM daemon:                                              [FAILED]
| Starting up APM daemon: execvp: No such file or directory
|                                                                        [FAILED]
| # echo $?
| 0

This is caused by a broken RETVAL=$? assignment in the restart()
function, see https://bugzilla.fedora.us/show_bug.cgi?id=346#c7 for
details.


Version-Release number of selected component (if applicable):

apmd-3.0.2-19
Comment 1 Bill Nottingham 2003-10-22 17:10:27 EDT
fixed in 3.0.2-20

Note You need to log in before you can comment on or make changes to this bug.