Bug 977816 - Safe graphics mode missing for Live UEFI
Summary: Safe graphics mode missing for Live UEFI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 11:50 UTC by Kamil Páral
Modified: 2015-01-09 21:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-09 21:36:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 855824 None CLOSED vesa driver is not used in virtual machines 2019-09-18 15:47:53 UTC
Red Hat Bugzilla 858270 None CLOSED 'Basic graphics mode' relies on specifying a fallback driver (vesa), should rather ask X to perform a system/firmware-ap... 2019-09-18 15:47:53 UTC
Red Hat Bugzilla 1009828 None CLOSED UEFI boot menu doesn't contain safe graphics mode 2019-09-18 15:47:52 UTC

Internal Links: 855824 858270 1009828

Description Kamil Páral 2013-06-25 11:50:32 UTC
Description of problem:
"Boot in safe graphics mode" option is missing on the Live medium, when booted in UEFI mode. It also affects any ISO->USB conversion method.

The safe graphics mode is present with DVD/netinst.

Version-Release number of selected component (if applicable):
F19 RC1

Comment 1 Kamil Páral 2013-06-25 12:26:06 UTC
Seems to be a blocker:
The boot menu for all supported installer and live images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer or desktop and attempting to use the generic driver.
https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Expected_image_boot_behavior

Comment 2 Kamil Páral 2013-06-25 15:18:58 UTC
Note: A memtest option is also missing, because there is not Troubleshooting menu at all.

Comment 3 Jaroslav Reznik 2013-06-25 15:30:56 UTC
It's not regression as this is not supported for many releases - bcl points to ceb81892 (Jeremy Katz 2008-06-05 21:04:40 -0400) in livemedia-creator. I tried it with F18, F17 and I can confirm that, -1 blocker.

Comment 4 Adam Williamson 2013-06-25 15:53:32 UTC
Yeah, -1 blocker, that criterion was written with reference to the BIOS images. I've been meaning to look into making the UEFI boot menus better for *years* now.

Comment 5 Kevin Fenzi 2013-06-25 16:14:27 UTC
Is there actually a way to boot in basic video in efi mode then?

-1 blocker, but it would be nice to clarify this in docs.

Comment 6 drago01 2013-06-25 16:25:34 UTC
-1 this has always been like that afaik.

Comment 7 Adam Williamson 2013-06-25 16:36:33 UTC
Kevin: Probably not, but then, we probably couldn't actually do it just by adding a boot menu option either.

So on BIOS mode, 'basic video mode' just adds two kernel parameters: 'nomodeset xdriver=vesa'. The second is a complete no-op and has been for several releases:

https://bugzilla.redhat.com/show_bug.cgi?id=858270

fortuitously, though, since the modern X drivers for the major cards - nouveau, radeon, intel - all require KMS, simply passing 'nomodeset' has the effect we want: you wind up getting vesa as the fallback driver, because the main driver refuses to load without KMS.

You can trivially reproduce the bit that actually works - passing 'nomodeset' for UEFI, of course. Just edit the kernel parameters and add 'nomodeset'. I have no idea if this actually results in anything like what you actually want to happen, though. Probably not.

Ajax explains what we probably ought to do here in https://bugzilla.redhat.com/show_bug.cgi?id=858270#c2 : we need to add a feature to X which is basically 'please explicitly load the appropriate failsafe fallback configuration for my video hardware'. We really ought to get that done. But it's not an F19 blocker.

-3 votes here, setting RejectedBlocker.

Comment 8 Kamil Páral 2013-06-25 16:39:31 UTC
Please note that I have tested safe graphics mode on DVD/netinst in UEFI mode and it worked as expected - it ran in low-res and looked very ugly, just as with BIOS mode :)

Comment 9 Adam Williamson 2013-06-25 16:50:14 UTC
Kamil: I'm not at all sure we can rely on that for all hardware, though; I don't know _all_ the details but I think it may well be the case that some UEFI firmwares just won't handle 'nomodeset' well at all.

Comment 10 Dennis Gilmore 2013-06-25 16:59:31 UTC
-1 AFAIK memtest doesnt work in UEFI mode

Comment 11 Chris Murphy 2013-06-25 19:35:38 UTC
At least with 19 final FC1 on a Mac booted EFI which has GOP (per the UEFI spec), nomodeset causes X to not start. It seems GOP support is needed rather than VESA, for a fallback basic video mode, I'm not seeing anything in the UEFI spec about VESA.

[    11.914] (II) [KMS] drm report modesetting isn't supported.
[    11.914] (WW) Falling back to old probe method for modesetting
[    11.914] (EE) open /dev/dri/card0: No such file or directory
[    11.914] (WW) Falling back to old probe method for fbdev
[    11.931] (EE) Screen 0 deleted because of no matching config section.
[    11.936] (EE) VESA(0): V_BIOS address 0x0 out of range
[    11.937] (EE) Screen(s) found, but none have a usable configuration.

Comment 12 Chris Murphy 2013-06-25 20:46:13 UTC
With F18 kernel 3.6.10, nomodeset works on the same EFI GOP hardware. Sorta. I get graphics but they're totally garbled. F19 fails with this message:
[    11.936] (EE) VESA(0): V_BIOS address 0x0 out of range

Whereas the VESA driver on F18 finds what it's looking for vbios wise, but it just gets the resolution and refresh wrong so things don't display correctly.

Comment 13 Fedora End Of Life 2015-01-09 18:32:00 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 14 Adam Williamson 2015-01-09 20:36:17 UTC
So in F21 the 'basic graphics mode' option does *exist* for UEFI live, but it does the same as for BIOS, it just adds 'nomodeset'. I can never remember - mjg59, is this correct, or should it do something else?

Comment 15 Matthew Garrett 2015-01-09 21:31:12 UTC
nomodeset is all we can do from the kernel side. As long as X then falls back to a generic driver, we're good.

Comment 16 Adam Williamson 2015-01-09 21:36:33 UTC
ok, well it's certainly resolved as reported then. thanks matthew!


Note You need to log in before you can comment on or make changes to this bug.