Bug 1009828 - UEFI boot menu doesn't contain safe graphics mode
UEFI boot menu doesn't contain safe graphics mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
AcceptedBlocker
:
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-09-19 05:04 EDT by Kamil Páral
Modified: 2013-11-29 08:54 EST (History)
9 users (show)

See Also:
Fixed In Version: livecd-tools-20.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-29 08:54:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drop 'xdriver=vesa' from basic graphics mode parameters for live images (patch for upstream livecd-tools) (1.02 KB, patch)
2013-11-13 22:06 EST, Adam Williamson
no flags Details | Diff
drop 'xdriver=vesa' from basic graphics mode parameters for lorax-generated images (patch for upstream lorax) (2.81 KB, patch)
2013-11-13 22:13 EST, Adam Williamson
no flags Details | Diff
Xorg.0.log gnome-shell failure with nomodeset (9.09 KB, text/plain)
2013-11-14 18:39 EST, Chris Murphy
no flags Details
make UEFI live boot menu more similar to BIOS and non-live (1.71 KB, patch)
2013-11-14 19:10 EST, Adam Williamson
no flags Details | Diff
add troubleshooting submenu and basic graphics boot entry to UEFI live boot menu (1.23 KB, patch)
2013-11-14 19:10 EST, Adam Williamson
no flags Details | Diff

  None (edit)
Description Kamil Páral 2013-09-19 05:04:53 EDT
Description of problem:
Unlike BIOS boot menu, the UEFI boot menu on LiveCD doesn't contain any Troubleshooting menu, and therefore there is no "Safe graphics mode" menu.

We seem to require it:
"The boot menu for all supported installer and live images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer or desktop and attempting to use the generic driver."
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_image_boot_behavior

Safe graphics mode is available on netinst.

Version-Release number of selected component (if applicable):
F20 Alpha RC4

How reproducible:
always

Steps to Reproduce:
1. boot Live in UEFI mode
2. see no troubleshooting menu, just boot and verify & boot menus
Comment 1 Kamil Páral 2013-09-19 05:06:54 EDT
Proposing as Alpha blocker due to our criteria. However, please be aware that even if that menu is present, the safe graphics mode never worked properly on UEFI. I believe we really should fix it this time, UEFI machines start to be widely available. But I don't think this needs to block Alpha right now. Final would be enough.
Comment 2 Kamil Páral 2013-09-19 05:23:21 EDT
The same bug for F19: bug 977816. Rejected for F19, as it seems.
Comment 3 Mike Ruckman 2013-09-19 14:10:55 EDT
Discussed this in the F20 Alpha Go/No-Go meeting [1]. While unfortunate, basic video drivers have not ever worked on UEFI machines and this is not a regression in functionality. Therefore rejected as a release blocking bug for F20 alpha

[1] http://meetbot.fedoraproject.org/fedora-meeting-2/2013-09-19/
Comment 4 Chris Murphy 2013-09-19 16:05:52 EDT
(In reply to Mike Ruckman from comment #3)
I wonder what ajax thinks of this assertion. I've tested the basic video drivers on EFI 1.10 UGA and GOP hardware and they work. UEFI should be significantly more reliable still.
Comment 5 Kamil Páral 2013-09-20 03:37:59 EDT
Re-proposing for Final.
Comment 6 Adam Williamson 2013-11-12 20:20:38 EST
cmurf: I think the note rather means that 'we've never actually provided a working boot menu entry for fallback graphics on UEFI', not that UEFI fallback drivers themselves don't work properly.

We really should either a) fix up the UEFI boot menus with a plausible 'fallback graphics' entry, or b) revise the criterion to apply only to non-UEFI boots at present.
Comment 7 Jaroslav Reznik 2013-11-13 07:08:13 EST
Indeed, as this bug is bouncing back mostly every single milestone for some time. Can we get more evidence how reliable basic video mode in EFI is?
Comment 8 Adam Williamson 2013-11-13 14:36:45 EST
Per ajax at today's blocker review meeting, just passing 'nomodeset' should be sufficient to set 'fallback mode' for UEFI graphics, and should now be the correct way to get 'fallback mode' for BIOS too. So the todo list here is:

1. Drop 'xdriver=vesa' from fallback mode parameters on all bootloaders
2. Add bootloader entry for fallback mode to UEFI live bootloader

I can work on that myself.
Comment 9 Adam Williamson 2013-11-13 14:40:41 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Accepted as a blocker per criterion cited in description. I will try to post patches for this.
Comment 10 Adam Williamson 2013-11-13 22:03:57 EST
I just checked this, and a Beta live USB stick I have here actually *does* have a Troubleshooting menu with a 'basic graphics mode' option that looks like it would work, when booted in UEFI mode. Kamil, can you look into this a bit more? Did you write your stick with litd or dd or luc or what?

In the meantime I can send patches to drop 'xdriver=vesa'.
Comment 11 Adam Williamson 2013-11-13 22:06:55 EST
Created attachment 823734 [details]
drop 'xdriver=vesa' from basic graphics mode parameters for live images (patch for upstream livecd-tools)

This patch is against upstream livecd-tools - git://git.fedorahosted.org/git/livecd - and it should drop 'xdriver=vesa' from the parameters used for the 'basic graphics mode' boot on live images.
Comment 12 Adam Williamson 2013-11-13 22:08:02 EST
CCing bcl as he is the owner of upstream livecd-tools.
Comment 13 Adam Williamson 2013-11-13 22:13:37 EST
Created attachment 823735 [details]
drop 'xdriver=vesa' from basic graphics mode parameters for lorax-generated images (patch for upstream lorax)

This patch should drop 'xdriver=vesa' for all lorax-generated images, patch is against current upstream lorax master.
Comment 14 Kamil Páral 2013-11-14 07:38:02 EST
I tested F20 Beta x86_64 Live with UEFI boot:

cdrom: no safe graphics mode option
dd: no safe graphics mode option
litd: no safe graphics mode option
luc: no safe graphics mode option

Adam, are you sure you booted in UEFI mode?
Comment 15 Adam Williamson 2013-11-14 11:55:36 EST
Yes, though it's possible that wasn't actually a live image. Just wrote a new stick from the desktop live image and that one doesn't have the troubleshooting menu in it.

I'll try and send a patch that adds it today.
Comment 16 Brian Lane 2013-11-14 14:02:47 EST
That patch will remove it from bios. grub in livecd-tools doesn't include the troubleshooting menu, but lmc does.
Comment 17 Adam Williamson 2013-11-14 14:05:33 EST
bcl: not quite sure of the significance of your comment, but AIUI, with the patches I've sent so far, all the cases where we actually display a troubleshooting menu with a basic graphics mode option should be 'correct' - they pass 'nomodeset' but not 'xdriver=vesa'. The patch to livecd-tools covers the live-image-booted-BIOS case, and the patch to lorax should cover non-live images whether booted via BIOS or UEFI, unless I missed something.

The missing piece is to add the Troubleshooting menu to the grub.cfg generated by livecd-tools' live.py and used by live images booted in UEFI mode, with a correct 'basic graphics mode' entry. I was planning to work on that today - I can see basically how to do it, it's just fairly obvious changes to live.py , but if you want to do it I'm sure you could do it faster than me.
Comment 18 Chris Murphy 2013-11-14 18:19:27 EST
Passing nomodeset does not work on two EFI Macs. tty1 hangs at gnome-shell load time, I can switch to a functioning tty2.

Fedora 20 beta (final)
xorg-x11-server-1.14.3-4.fc20.src.rpm  

It worked in July when I tested with xorg-x11-server-1.14.2-3.fc19.uefi1.src.rpm from:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5596647
https://lists.fedoraproject.org/pipermail/test/2013-July/116930.html
Comment 19 Chris Murphy 2013-11-14 18:39:26 EST
Created attachment 824181 [details]
Xorg.0.log gnome-shell failure with nomodeset
Comment 20 Adam Williamson 2013-11-14 19:08:23 EST
Chris: please file a separate bug to avoid confusion. This bug is about providing the option, not troubleshooting cases where booting with the option doesn't work.
Comment 21 Adam Williamson 2013-11-14 19:10:24 EST
Created attachment 824183 [details]
make UEFI live boot menu more similar to BIOS and non-live

Can't send patches to anaconda-patches@ for some reason, so continuing to attach here. I have two more patches for livecd-tools that make the UEFI live boot menu resemble the BIOS live and the non-live boot menus better, and add a Troubleshooting submenu with the 'basic graphics mode' entry. Attaching those.
Comment 22 Adam Williamson 2013-11-14 19:10:54 EST
Created attachment 824184 [details]
add troubleshooting submenu and basic graphics boot entry to UEFI live boot menu
Comment 23 Adam Williamson 2013-11-14 19:11:48 EST
Assigning to bcl as I've written and provided the patches, up to him to apply, don't think I have the rights.
Comment 24 Chris Murphy 2013-11-14 19:19:45 EST
Done. See bug 1030695.
Comment 25 Fedora Update System 2013-11-18 18:10:16 EST
lorax-20.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lorax-20.4-1.fc20
Comment 26 Fedora Update System 2013-11-18 18:11:17 EST
livecd-tools-20.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/livecd-tools-20.1-1.fc20
Comment 27 Fedora Update System 2013-11-19 16:52:09 EST
Package livecd-tools-20.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-20.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21725/livecd-tools-20.1-1.fc20
then log in and leave karma (feedback).
Comment 28 Jan Sedlák 2013-11-21 09:17:15 EST
Tested F20 TC2 64bit using dd, liveiso-to-disk and livecd-creator with usb stick and brasero with DVD. Both BIOS and UEFI bootloaders have "basic graphics" item in menu with "nomodeset" (and no "xdriver") parameter in kernel lines.
Comment 29 Jan Sedlák 2013-11-21 09:25:58 EST
To clarify it, I have tested netinst, DVD and Live and all of them have basic video option in bootloader.
Comment 30 Fedora Update System 2013-11-25 23:52:41 EST
lorax-20.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Fedora Update System 2013-11-29 08:54:54 EST
livecd-tools-20.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.