This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977833 - Anaconda should install language pack
Anaconda should install language pack
Status: CLOSED DUPLICATE of bug 981804
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 08:48 EDT by Chris Smart
Modified: 2013-08-02 15:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 15:47:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Smart 2013-06-25 08:48:04 EDT
Description of problem:
Fedora Live CD's come in English but when you install Fedora from a live cd and select a language it would be nice if the resulting system got full support for that language.

* Post install from KDE spin you still get everything in English (except tty).
* Post install from Desktop you get your language in GNOME but no dictionaries, fonts, or other support.

This could be solved if Anaconda did a post install process of installing the language pack of the language chosen during install with (this would require checks for Internet though):
  yum langinstall <locale>

Plus, the way to set the language post install is different for every desktop.

How reproducible:
Every time.

Steps to Reproduce:
1. Load Fedora live image
2. Select language other than English
3. Boot into new system

Actual results:
The resulting system is all English (in case of KDE) and in case of GNOME you have no dictionary or other support (although GNOME is translated).

Expected results:
The resulting system should be in the language you selected and it should have full support for it.
Comment 1 Steve Tyler 2013-07-18 23:12:57 EDT
Thanks for your report.

This appears to be a duplicate:
Bug 981804 - Even if Fedora main language is set to French, Libreoffice is installed and use English.
Comment 2 David Shea 2013-08-02 15:47:25 EDT
Marking as a duplicate of 981804 since there's more info there. 981804 is specifically about libreoffice, but the underlying problem is the same: when and how the langpack packages get installed.

*** This bug has been marked as a duplicate of bug 981804 ***

Note You need to log in before you can comment on or make changes to this bug.