Bug 981804 - Even if Fedora main language is set to French, Libreoffice is installed and use English.
Even if Fedora main language is set to French, Libreoffice is installed and u...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 977833 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 17:09 EDT by thcourbon
Modified: 2014-02-20 16:26 EST (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-20 16:17:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thcourbon 2013-07-05 17:09:20 EDT
Description of problem:
Having installed Fedora and selected both during install and after installation french as the prefered language, Libreoffice was installed and display its menus in english.

Version-Release number of selected component (if applicable):
Writer version fo isntance : 4.1.0.1-8.fc19

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora in French (possibly in a another language)
2. Selected French as the prefered language.
3. run yum install libreoffice

Actual results:
Writer is in English

Expected results:
Wrtier is in French
Comment 1 David Tardon 2013-07-08 06:26:13 EDT
... which is not a libreoffice problem at all.
Comment 2 Ales Kozumplik 2013-07-08 07:05:23 EDT
As explained on IRC, I very much doubt this has anything to do with Yum. For instance, libreoffice should run just as fine and translated if installed from an .rpm directly.
Comment 3 David Tardon 2013-07-08 07:16:40 EDT
"Something" has to install libreoffice-langpack-fr. I do not know if that "something" is/should be yum, or where it takes the data. But apparently it can do it, because "yum langinstall fr" works.
Comment 4 Jan Zeleny 2013-07-16 03:40:40 EDT
Judging from the available information, it looks like something goes wrong during the installation process and the langpack is not properly installed. Reassigning to Anaconda for inspection.
Comment 5 Steve Tyler 2013-07-16 11:01:47 EDT
How are you installing? Live? DVD? netinst? kickstart?
Comment 6 Steve Tyler 2013-07-16 11:13:07 EDT
What do does this show?
$ locale
$ rpm -qa 'libreoffice*' | sort
Comment 7 Steve Tyler 2013-07-16 11:26:59 EDT
I cannot reproduce this:

1. Install from the F19 DVD.
2. Select French as the language from the Welcome screen.
3. Select the Gnome desktop (LibreOffice is automatically selected).
4. Select default disk partitioning.

"locale" shows fr_FR.UTF-8.
libreoffice-langpack-fr is installed.
LibreWriter displays menus in French.

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 8 Steve Tyler 2013-07-16 12:37:03 EDT
Reproduced with the Live image:

1. Install from the F19 Live Desktop (Gnome) image.
2. Select French as the language from the Welcome screen.
3. Select default disk partitioning.

"locale" shows fr_FR.UTF-8.
libreoffice-writer is installed.
libreoffice-langpack-fr is _not_ installed.
LibreWriter displays menus in English.

# A post-install update that includes libreoffice-core and libreoffice-writer does not pull in libreoffice-langpack-fr:
$ sudo yum update -y

After updating and installing libreoffice-langpack-fr, LibreWriter crashes:
$ sudo yum install libreoffice-langpack-fr -y

After rebooting, LibreWriter displays menus in French.

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-Live-Desktop-x86_64-19-1.iso -vga std -boot menu=on
Comment 9 Steve Tyler 2013-07-16 12:47:14 EDT
The problem is that the libreoffice langpack packages are not on the Live image. Since the Live installer just copies files from the Live image to the target, these are the only ones that get installed:

[liveuser@localhost ~]$ rpm -qa 'libreoffice*' | sort
libreoffice-calc-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-core-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-draw-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-graphicfilter-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-impress-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-opensymbol-fonts-4.1.0.0-9.beta2.fc19.noarch
libreoffice-pdfimport-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-ure-4.1.0.0-9.beta2.fc19.x86_64
libreoffice-writer-4.1.0.0-9.beta2.fc19.x86_64
[liveuser@localhost ~]$ uname -a
Linux localhost 3.9.5-301.fc19.x86_64 #1 SMP Tue Jun 11 19:39:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[liveuser@localhost ~]$
Comment 10 Steve Tyler 2013-07-16 13:10:45 EDT
(In reply to thcourbon from comment #0)
...
> Steps to Reproduce:
> 1. Install Fedora in French (possibly in a another language)
> 2. Selected French as the prefered language.
> 3. run yum install libreoffice
...

Could you try running:
$ sudo yum install libreoffice-langpack-fr
Comment 11 Steve Tyler 2013-07-16 14:00:35 EDT
Couldn't LibreWriter be smart enough to notice that if the locale is fr, and it is missing all of its French translations, then it should report that to the user?

As it is, the user has installed in French, yet there is no explanation as to why the LibreWriter menus are being displayed in English. That is not user-friendly!

Suggest reassigning to component libreoffice.
Comment 12 thcourbon 2013-07-17 13:04:56 EDT
Hello Steve,

I was away for work the last 2 days so I was't able to answer.

Indeed I installed fedora with the Gnome live CD. 

I tested again and I had to yum landinstall fr after the install to get the desktop in french and then yum install libreoffice-langpack-fr to get libreoffice in french. So in fact it may not be libreoffice related but a bug in the live cd installer since I had to install the language after completion ?
Comment 13 Caolan McNamara 2013-07-17 15:38:31 EDT
I guess in libreoffice we could attempt a packagekit prompt to install libreoffice-langpack-LOCALE packages if there isn't installed matching UI language support to the locale.
Comment 14 Steve Tyler 2013-07-17 17:47:03 EDT
Thanks, thcourbon and Caolan.

I'm not sure why the libreoffice-langpack-* packages are not on the Live image. It could be due to space limitations. The relevant component is spin-kickstarts:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/

Prompting the user to install a missing libreoffice-langpack-* package sounds like a good idea.
Comment 15 Steve Tyler 2013-07-17 18:01:18 EDT
(In reply to Steve Tyler from comment #14)
...
> I'm not sure why the libreoffice-langpack-* packages are not on the Live
> image. It could be due to space limitations.
...

"libreoffice is too big to fit on CD sized images."
Bruno Wolff III 2011-10-17 19:06:06 UTC
Bug 746740, Comment 2.

The F19 Live images are now in fact larger than CD-sized, but less than 1 GB:

$ ls -1sh *.iso
4.3G Fedora-19-i386-DVD.iso
4.2G Fedora-19-x86_64-DVD.iso
318M Fedora-19-x86_64-netinst.iso
920M Fedora-Live-Desktop-i686-19-1.iso
952M Fedora-Live-Desktop-x86_64-19-1.iso
Comment 16 Steve Tyler 2013-07-17 18:27:16 EDT
Bruno: Could we get your authoritative comment as to why the libreoffice-langpack-* packages are not on the Live image?
Comment 17 Bruno Wolff III 2013-07-17 21:40:57 EDT
I didn't decide what is installed on gnome desktop. If the local specific versions are not specifically selected in the kickstart file or brought in as a dependency, then they won't be on the live image. Installing all of the locale specific packages would make the live images bigger than people want. (It was a struggle to get the live desktop image under its target size as it was). Note that there are kickstart files that can be used to build live images that support specific locales. There is for example a fedora-livecd-desktop-fr_FR.ks that can be use to build one for French. It is included in the l10n-kickstarts package.
Comment 18 Steve Tyler 2013-07-18 01:02:21 EDT
Thanks, Bruno. Space is an ongoing problem with Live images:

Here is a search for "space" in the spin-kickstarts log messages:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/log/?qt=grep&q=space

Do the libreoffice developers want to reassign this to themselves, or should we reassign it to spin-kickstarts first? ;-)
Comment 19 Bruno Wolff III 2013-07-18 09:46:09 EDT
This is a best an RFE and under the current conditions we aren't going to be including multiple locales in live images. Not are we going to make multiple ISOs for each spin per locale. The solution now is to make your own Live ISO using one the the locale specific kickstart files. People can consider putting up unofficial ISOs, but they should make sure they can meet GPL requirements if they do.

In the future when bandwidth and storage are cheaper and there are more people helping with QA and release engineering, things might be different.
Comment 20 Steve Tyler 2013-07-18 10:35:05 EDT
Thanks, Bruno. What do you think of Caolan's suggestion re libreoffice prompting the user to install a missing langpack (Comment 13)?

Since langpacks are not going to be included on the Fedora Gnome Desktop Live images anytime soon, ISTM that would be a good solution.
Comment 21 Bruno Wolff III 2013-07-18 11:39:23 EDT
That's outside of the scope of spins. I don't have strong feelings either way as to whether that is a good idea or not. It might be worth doing some brain storming for a more general solution before going to the libreoffice people. The devel list might be a place to talk about how to provide a better experience for people that need locale specific packages installed.
Comment 22 Steve Tyler 2013-07-18 15:08:19 EDT
(In reply to Bruno Wolff III from comment #21)
> ... brain storming ...

Bruno, you give me a brain storm ... :-)

PackageKit already automatically prompts the user to install updates.
Those updates should include missing langpacks.

Could someone reassign to PackageKit for comment?
Comment 23 Steve Tyler 2013-07-18 16:12:12 EDT
After installing in French from the Gnome Live image and rebooting, I let PackageKit install updates. No libreoffice-langpacks-* were installed.

See also:
Bug 734976 - libreoffice-langpack-*-* not pulled in by yum install libreoffice 

Tested with:
$ qemu-img create f19-test-2.img 12G
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-Live-Desktop-x86_64-19-1.iso -vga std -boot menu=on
Comment 24 Steve Tyler 2013-07-18 16:30:57 EDT
(In reply to Steve Tyler from comment #23)
> After installing in French from the Gnome Live image and rebooting, I let
> PackageKit install updates. No libreoffice-langpacks-* were installed.
...

Doesn't the yum langpacks plugin already support this use-case?
yum-langpacks-0.3.1-2.fc19.noarch
Comment 25 Steve Tyler 2013-07-18 23:13:39 EDT
See also:
Bug 977833 - Anaconda should install language pack
Comment 26 Jan Zeleny 2013-07-19 02:41:12 EDT
(In reply to Steve Tyler from comment #24)
> (In reply to Steve Tyler from comment #23)
> > After installing in French from the Gnome Live image and rebooting, I let
> > PackageKit install updates. No libreoffice-langpacks-* were installed.
> ...
> 
> Doesn't the yum langpacks plugin already support this use-case?
> yum-langpacks-0.3.1-2.fc19.noarch

I'm afraid I'm not the right guy to ask, as I'm not the author. Bill Nottingham (adding to CC) is the co-author and maintainer of the plugin, he is the one to answer this.
Comment 27 Steve Tyler 2013-07-19 11:47:28 EDT
Thanks, Jan. Now I see that yum-langpacks is a separate component.

This has been a problem before ... :-(

"Bill says that yum doesn't install the missing translations on first update because it only does it at install time, not update time."
Adam Williamson 2012-04-11 20:09:46 UTC
Bug 804216, Comment 4.
Comment 28 Bill Nottingham 2013-07-19 15:35:45 EDT
I assume doing 'yum langinstall fr_FR' does the right thing?
Comment 29 Steve Tyler 2013-07-19 16:54:10 EDT
Yes. Manual installation works fine.

$ sudo yum langinstall fr_FR
...
Installé :
  autocorr-fr.noarch 1:4.1.0.1-8.fc19             hunspell-fr.noarch 0:4.6-3.fc19 hyphen-fr.noarch 0:2.0-7.fc19
  libreoffice-langpack-fr.x86_64 1:4.1.0.1-8.fc19 mythes-fr.noarch 0:2.3-3.fc19  

Language packs installed for: fr_FR
Comment 30 David Shea 2013-08-02 15:47:25 EDT
*** Bug 977833 has been marked as a duplicate of this bug. ***
Comment 31 Chris Smart 2013-08-02 18:42:16 EDT
The langinstall plugin(In reply to Steve Tyler from comment #20)
> Thanks, Bruno. What do you think of Caolan's suggestion re libreoffice
> prompting the user to install a missing langpack (Comment 13)?
> 
> Since langpacks are not going to be included on the Fedora Gnome Desktop
> Live images anytime soon, ISTM that would be a good solution.

I think maybe this should be more system-wide, rather than application specific (or in addition to). There are other components missing when a user installs Fedora with a non-US English language, such as dictionaries, KDE i10n package, man pages translations, fonts, etc.

For example, installing Fedora KDE live image and selecting French will get you the entire system in English, because kde-l10n-French isn't on the Live image - never mind the fact that LibreOffice is in English.

Perhaps when the user logs on, PackageKit could do a check then?

-c
Comment 32 Chris Smart 2013-08-02 18:46:54 EDT
(In reply to Chris Smart from comment #31)
> 
> Perhaps when the user logs on, PackageKit could do a check then?
> 

Or perhaps at the time of install, if a user has Internet access then Anaconda could prompt to install the required langpack into the chroot. This way it will work on first boot and langpacks don't need to be included on the Live media (which they won't be anyway).

If there is no internet access during time of install, Anaconda could set a flag for PackageKit to notify the user on first log in (whether Internet access or no).

-c
Comment 33 Steve Tyler 2013-08-02 22:24:16 EDT
Bill: Do you think that yum-langpacks could be enhanced to install missing, locale-specific langpacks as part of a routine update?

Chris: The Live image installer simply copies files from the image to the install destination (Comment 9). There is no support for install source selection with the Live image installer. The anaconda developers would be better qualified than I am to comment on your suggestion.

PackageKit is basically a front-end for yum that checks for updates at firstboot and periodically thereafter. The firstboot update could install missing langpacks even if there are no other packages that need updating.
Comment 34 Bill Nottingham 2013-08-05 15:59:56 EDT
(In reply to Steve Tyler from comment #33)
> Bill: Do you think that yum-langpacks could be enhanced to install missing,
> locale-specific langpacks as part of a routine update?

... maybe? The issue would be when to trigger this behavior - randomly pulling in needed langpacks on 'yum update bash' would obviously be strange.
Comment 35 Steve Tyler 2013-08-05 16:25:31 EDT
Thanks for pointing that out. Do you see any side-effects from pulling in needed langpacks when no specific packages are listed?

$ sudo yum update # no packages listed; update everything and pull in langpacks
Comment 36 Michael Lipp 2014-01-27 05:05:56 EST
I just came across this, because I wondered why my libreoffice UI wouldn't show up in German. The thread was very helpful. I didn't know about "yum install langpack de" (how could I?). Having used Ubuntu for a long time, I remember that they have some "check program" that pops up a prompt if you log in with a language that isn't fully supported (i.e. localisations for installed programs are missing). I don't know what component does this and how packages (like libreoffice) "register" in order to be considered in the check, but it certainly avoids (end) user confusion.
Comment 37 David Shea 2014-02-20 16:17:27 EST
It looks like the langpack plugin is doing whatever it needs to do now.

Note You need to log in before you can comment on or make changes to this bug.