Bug 977855 - auto-attach preference does nothing in subscription-manager-gui
auto-attach preference does nothing in subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-25 09:19 EDT by J.C. Molet
Modified: 2013-09-30 19:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:11:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Prefrences dialgue when auto-attach oprtion unchecked (104.71 KB, image/png)
2013-07-15 05:32 EDT, Shwetha Kallesh
no flags Details
Prefrences dialgue when auto-attach option checked (102.25 KB, image/png)
2013-07-15 05:33 EDT, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 18:49:24 EDT

  None (edit)
Description J.C. Molet 2013-06-25 09:19:32 EDT
Description of problem:
In the preferences dialog in subscription-manager-gui, the option to set your auto-attach preference doesn't seem to do anything.

Version-Release number of selected component (if applicable):
[root@jmolet-vm0 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.15-1
subscription-manager: 1.8.11-1.git.12.6650553.el5
python-rhsm: 1.8.12-1.git.0.d747a65.el5


How reproducible:
always

Steps to Reproduce:
1. start up subscription-manager-gui
2. Register to your friendly neighborhood candlepin
3. go to System > Preferences
4. uncheck the auto-attach preference to disabled
5. close the preferences dialog
6. go to System > Preferences to reopen the dialog

Actual results:
Nothing changes, the supposedly disabled preference stays checked as enabled.
toggling this switch changes nothing on the consumer.

Expected results:
The change persists and updates the consumer.

Additional info:
Comment 1 RHEL Product and Program Management 2013-06-25 09:48:47 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Cory Scheviak 2013-07-11 15:01:18 EDT
43845092ef68f249f400e15c17a099d8d9221631
Comment 3 Shwetha Kallesh 2013-07-15 05:32:29 EDT
Created attachment 773669 [details]
Prefrences dialgue when auto-attach oprtion unchecked

[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.16-1
subscription-manager: 1.8.13-1.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5
Comment 4 Shwetha Kallesh 2013-07-15 05:33:43 EDT
Created attachment 773671 [details]
Prefrences dialgue when auto-attach option checked
Comment 8 errata-xmlrpc 2013-09-30 19:11:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.