Bug 977881 - Cassandra Plugin - Cassandra server is discovered and inventoried - exceptions in agent log
Cassandra Plugin - Cassandra server is discovered and inventoried - exception...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory (Show other bugs)
JON 3.2
Unspecified Unspecified
low Severity high
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-06-25 10:12 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:34:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cassandra_agent.log (33.67 KB, text/x-log)
2013-06-25 10:12 EDT, Armine Hovsepyan
no flags Details
cass_1.2.9.png (362.95 KB, image/png)
2013-09-20 10:11 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-06-25 10:12:38 EDT
Created attachment 765100 [details]
cassandra_agent.log

Description of problem:
Cassandra Plugin - Cassandra server is discovered and inventoried - exceptions in agent log

Version-Release number of selected component (if applicable):
build: 983670c

How reproducible:
always

Steps to Reproduce:
1. install and start apache cassandra
2. run rhqctl install
3.

Actual results:
storage node is discovered bu storage plugin
apache cassandra is discovered by cassandra plugin
apache cassandra server is not available - errors in agent.log


Expected results:
storage node is discovered bu storage plugin
apache cassandra is discovered by cassandra plugin
apache cassandra server is  available without errors in agent.log

Additional info:
Comment 1 John Sanda 2013-06-26 09:05:42 EDT
I need some additional info. Did you install and start a regular Cassandra instance as well as an RHQ storage node? If you installed a regular Cassandra instance, what version is it?
Comment 2 Armine Hovsepyan 2013-06-26 09:22:27 EDT
both rhq storage node (rhq cassandra) and regular cassandra instances installed.
regular cassnadra version 1.2.5
Comment 3 Charles Crouch 2013-07-01 15:19:51 EDT
Per 7/1 BZ triage: target jon32
Comment 4 John Sanda 2013-07-01 17:26:23 EDT
This is a community issue, not a product issue. I spoke with Armine and the problem is with the Cassandra plugin trying to manage an instance of Cassandra 1.2.5. We are currently on 1.2.4 and as such have not tested 1.2.5 or 1.2.6.
Comment 5 John Sanda 2013-08-22 21:53:56 EDT
I am lowering the priority on this since we are currently on Cassandra 1.2.4. Managing later versions is not an issue for JON 3.2. With respect to JON 3.2., the only concern is the version used by the rhq-storage plugin.
Comment 6 Heiko W. Rupp 2013-09-06 11:58:34 EDT
Now that we are on C* 1.2.9 (?) how much does this still apply?
Comment 7 Armine Hovsepyan 2013-09-09 09:31:55 EDT
moving to on_qa for checking with jon 3.2 er1 build
Comment 8 Armine Hovsepyan 2013-09-20 10:11:51 EDT
Created attachment 800515 [details]
cass_1.2.9.png
Comment 9 Armine Hovsepyan 2013-09-20 10:12:20 EDT
verified with apache-cassandra 1.2.9

Note You need to log in before you can comment on or make changes to this bug.