Bug 977918 - Dangling symlinks in openshift-origin-cartridge-ruby package
Dangling symlinks in openshift-origin-cartridge-ruby package
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On: 977916
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:08 EDT by Jason DeTiberus
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-origin-cartridge-ruby-0.4.10.2-1.el6op.noarch.rpm
Doc Type: Bug Fix
Doc Text:
The openshift-origin-cartridge-ruby source code contained an unnecessary symlink with a missing target. This symlink was packaged into a broken symlink in the build. With this fix, the symlink has been removed from the source code and the broken symlink no longer appears.
Story Points: ---
Clone Of: 977916
Environment:
Last Closed: 2013-08-05 13:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-06-25 11:08:50 EDT
+++ This bug was initially created as a clone of Bug #977916 +++

Description of problem:
openshift-origin-cartridge-ruby has dangling symlinks: 
File usr/libexec/openshift/cartridges/v2/ruby/versions/1.8/metadata is a dangling symlink (to ../shared/metadata/) on noarch
File usr/libexec/openshift/cartridges/v2/ruby/versions/1.9/metadata is a dangling symlink (to ../shared/metadata/) on noarch

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Install package
2. ls -l /usr/libexec/openshift/cartridges/v2/ruby/versions/1.8/metadata
3. ls -l /usr/libexec/openshift/cartridges/v2/ruby/versions/1.9/metadata

Actual results:
ls shows broken symlinks

Expected results:
symlinks should not exist

Additional info:
This looks to be left over from early v2 work where there was a versions/shared/metadata directory that no longer exists.
Comment 2 Luke Meyer 2013-07-18 15:42:10 EDT
https://github.com/openshift/enterprise-server/pull/110

cherry-picked:
commit 7e8d61fcb6b7cd8a541a318e01dbef7b0d8ace31
Author: Luke Meyer <lmeyer@redhat.com>
Date:   Thu Jul 18 14:20:59 2013 -0400

    <ruby cart> bug 977919 remove broken symlinks
Comment 4 Gaoyun Pei 2013-07-22 02:57:50 EDT
Check this on puddle 1.2/2013-07-19.1

The related links have been deleted:
[root@node versions]# ls -l /usr/libexec/openshift/cartridges/v2/ruby/versions/1.8/metadata
ls: cannot access /usr/libexec/openshift/cartridges/v2/ruby/versions/1.8/metadata: No such file or directory
[root@node versions]# ls -l /usr/libexec/openshift/cartridges/v2/ruby/versions/1.9/metadata
ls: cannot access /usr/libexec/openshift/cartridges/v2/ruby/versions/1.9/metadata: No such file or directory

And no broken links under the ruby dir, so move it to VERIFIED.
[root@node versions]# tree .
.
├── 1.8
│   ├── etc
│   │   ├── conf -> ../../shared/etc/conf
│   │   └── conf.d
│   │       └── openshift.conf.erb
│   └── template
│       ├── config.ru
│       ├── public -> ../../shared/template/public/
│       ├── README.md -> ../../shared/template/README.md
│       └── tmp -> ../../shared/template/tmp/
├── 1.9
│   ├── etc
│   │   ├── conf -> ../../shared/etc/conf
│   │   └── conf.d
│   │       └── openshift.conf.erb
│   └── template
│       ├── config.ru
│       ├── public -> ../../shared/template/public/
│       ├── README.md -> ../../shared/template/README.md
│       ├── thread-dumper.rb
│       └── tmp -> ../../shared/template/tmp/
└── shared
    ├── etc
    │   ├── conf
    │   │   ├── httpd.conf
    │   │   └── httpd_nolog.conf
    │   └── conf.d
    │       └── openshift.conf.erb
    └── template
        ├── config.ru
        ├── public
        ├── README.md
        ├── thread-dumper.rb
        └── tmp
Comment 7 errata-xmlrpc 2013-08-05 13:17:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.