Bug 977925 - default_info allows any length of text for keyname
default_info allows any length of text for keyname
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity low
: rc
: 1.3
Assigned To: Adam Price
SAM QE List
:
Depends On:
Blocks: sam13-tracker 997161
  Show dependency treegraph
 
Reported: 2013-06-25 11:18 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 997161 (view as bug list)
Environment:
Last Closed: 2013-10-01 06:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jweiss: automate_bug+


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2013-06-25 11:18:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):
1.4.2-1.git.738.ee8619d.el6

How reproducible:


Steps to Reproduce:
1. Go to an org, select "System Default Info" menu item
2. Enter a string > 256 characters into the textbox (for example 300 'a's). 
3.

Actual results:
Keyname added

Expected results:
validation error:  Keyname must be <= 255 characters

Additional info:
Comment 1 Jeff Weiss 2013-06-25 14:38:12 EDT
Note, this bug is more severe than the above description.

If you then try to register a system to that org, you get
Validation failed: Keyname is too long (maximum is 255 characters)
Comment 2 Adam Price 2013-08-02 11:01:07 EDT
https://github.com/Katello/katello/pull/2716
Comment 4 sthirugn@redhat.com 2013-09-09 23:06:36 EDT
Verified:

* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-12.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-12.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-12.el6sam_splice.noarch
* katello-headpin-1.4.3-12.el6sam_splice.noarch
* katello-headpin-all-1.4.3-12.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 06:59:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.