Bug 997161 - default_info allows any length of text for keyname
default_info allows any length of text for keyname
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On: 977925
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 15:35 EDT by Bryan Kearney
Modified: 2014-08-12 12:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 977925
Environment:
Last Closed: 2014-08-12 12:39:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-08-14 15:35:33 EDT
+++ This bug was initially created as a clone of Bug #977925 +++

Description of problem:


Version-Release number of selected component (if applicable):
1.4.2-1.git.738.ee8619d.el6

How reproducible:


Steps to Reproduce:
1. Go to an org, select "System Default Info" menu item
2. Enter a string > 256 characters into the textbox (for example 300 'a's). 
3.

Actual results:
Keyname added

Expected results:
validation error:  Keyname must be <= 255 characters

Additional info:

--- Additional comment from Jeff Weiss on 2013-06-25 14:38:12 EDT ---

Note, this bug is more severe than the above description.

If you then try to register a system to that org, you get
Validation failed: Keyname is too long (maximum is 255 characters)

--- Additional comment from Adam Price on 2013-08-02 11:01:07 EDT ---

https://github.com/Katello/katello/pull/2716
Comment 1 RHEL Product and Program Management 2013-09-17 00:18:08 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Bryan Kearney 2014-08-12 12:39:47 EDT
This feature is not in Satellite6. I am closing it out.

Note You need to log in before you can comment on or make changes to this bug.