Bug 977962 - files not found after upgrade from F18 to F19
files not found after upgrade from F18 to F19
Status: CLOSED DUPLICATE of bug 975800
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 12:54 EDT by Kamil Páral
Modified: 2013-07-02 04:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 04:28:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error on boot (428.35 KB, image/jpeg)
2013-06-25 12:54 EDT, Kamil Páral
no flags Details
error on submenu (454.77 KB, image/jpeg)
2013-06-25 12:55 EDT, Kamil Páral
no flags Details
boot_contents (1.57 KB, text/plain)
2013-06-25 12:58 EDT, Kamil Páral
no flags Details
etc-default-grub (444 bytes, text/plain)
2013-06-25 12:58 EDT, Kamil Páral
no flags Details
fedup.log (538.80 KB, text/plain)
2013-06-25 12:58 EDT, Kamil Páral
no flags Details
grub.cfg (4.49 KB, text/plain)
2013-06-25 12:58 EDT, Kamil Páral
no flags Details
grub.cfg after re-running grub2-mkconfig (3.90 KB, text/plain)
2013-06-25 13:04 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-25 12:54:31 EDT
Description of problem:
I installed F18 in UEFI mode, then upgraded to F19. Every time I boot the machine, I see the following error messages:

> error: file `/grub2/themes/system/DejaVuSans-10.pf2' not found.
> error: file `/grub2/themes/system/DejaVuSans-12.pf2' not found.
> error: file `/grub2/themes/system/DejaVuSans-Bold-14.pf2' not found.
> error: file `/grub2/themes/system/theme.txt' not found.
> 
> Press any key to continue...

The errors are not fatal, I can get to the grub menu, but they are displayed on every boot.

Every time I click on any submenu in grub, I see one more error:

> error: file `/grub2/themes/system/theme.txt' not found.
> 
> Press any key to continue...

Again, not fatal, I can continue working.

Version-Release number of selected component (if applicable):
grub2-efi-2.00-22.fc19.x86_64

How reproducible:
tried one upgrade, happens on every boot

Steps to Reproduce:
1. install default F18 in UEFI
2. upgrade to F19
Comment 1 Kamil Páral 2013-06-25 12:54:57 EDT
Created attachment 765180 [details]
error on boot
Comment 2 Kamil Páral 2013-06-25 12:55:18 EDT
Created attachment 765181 [details]
error on submenu
Comment 3 Kamil Páral 2013-06-25 12:58:21 EDT
Created attachment 765182 [details]
boot_contents
Comment 4 Kamil Páral 2013-06-25 12:58:26 EDT
Created attachment 765183 [details]
etc-default-grub
Comment 5 Kamil Páral 2013-06-25 12:58:33 EDT
Created attachment 765184 [details]
fedup.log
Comment 6 Kamil Páral 2013-06-25 12:58:55 EDT
Created attachment 765185 [details]
grub.cfg
Comment 7 Kamil Páral 2013-06-25 13:00:43 EDT
When I ran "grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg", the problem disappeared. But that won't happen for general users, or will it?
Comment 8 Kamil Páral 2013-06-25 13:04:48 EDT
Created attachment 765187 [details]
grub.cfg after re-running grub2-mkconfig

I noticed that in the new grub.cfg these lines are gone:

> loadfont ($root)/grub2/themes/system/DejaVuSans-10.pf2
> loadfont ($root)/grub2/themes/system/DejaVuSans-12.pf2
> loadfont ($root)/grub2/themes/system/DejaVuSans-Bold-14.pf2
> set theme=($root)/grub2/themes/system/theme.txt
> export theme

Shouldn't fedup take care of re-generating grub? Or of it did, why the theme lines weren't already removed?
Comment 9 Berend De Schouwer 2013-06-26 10:10:06 EDT
Same error, non-UEFI; F18 -> F19 upgrade.

grub2-2.00-22.fc19.x86_64
grub2-tools-2.00-22.fc19.x86_64
grub2-efi-2.00-22.fc19.x86_64
grub-efi-0.97-93.fc17.x86_64

I've got EFI and non-EFI grub because of Samsung.  Non-EFI boot at the moment.
Comment 10 Kamil Páral 2013-06-26 10:26:19 EDT
I have reproduced the same with i386 upgrade. It seems to affect all architectures.
Comment 11 Kamil Páral 2013-06-26 10:27:44 EDT
CCing Will Woods. Will, is this something that should be fixed inside fedup, or inside grub?
Comment 12 Will Woods 2013-06-26 15:10:17 EDT
The answer is always "package problems belong to the packagers". I can't be an expert on the config files for every package in Fedora. 

If the snmpd config needed to be updated, you'd ask the net-snmp maintainers.
If the PAM config needed to be updated, you'd ask the pam maintainers.
So if the GRUB config needs to be updated, you ask the grub maintainers.

With that said: if I had to guess, I'd say this is probably another manifestation of whatever's happening in bug 975800.
Comment 13 Berend De Schouwer 2013-06-27 04:15:55 EDT
Probably not fedup.

I went F18 -> F19 a while ago.  It has been running fine for weeks (different Grub theme errors at different times, though, eg. bug 964375).  Grub was fine last week.  I have used PackageKit/yum to upgrade packages.

So, from /var/log/yum.log:

Jun 18 11:09:34 Updated: 1:grub2-tools-2.00-20.fc19.x86_64
Jun 18 11:10:40 Updated: 1:grub2-2.00-20.fc19.x86_64
Jun 18 11:10:42 Updated: 1:grub2-efi-2.00-20.fc19.x86_64
Jun 24 10:02:16 Updated: fedora-logos-19.0.4-2.fc19.noarch
Jun 24 10:02:18 Updated: 1:grub2-tools-2.00-22.fc19.x86_64
Jun 24 10:02:40 Updated: 1:grub2-efi-2.00-22.fc19.x86_64
Jun 24 10:02:41 Updated: 1:grub2-2.00-22.fc19.x86_64

I think June 24 broke it for me.
Comment 14 Kamil Páral 2013-07-02 04:28:41 EDT

*** This bug has been marked as a duplicate of bug 975800 ***

Note You need to log in before you can comment on or make changes to this bug.