Bug 97806 - pcmcia broken in BOOT kernel?
Summary: pcmcia broken in BOOT kernel?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: alpha 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-06-21 16:45 UTC by Alexandre Oliva
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-25 00:44:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2003-06-21 16:45:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030613

Description of problem:
I couldn't install Cambridge-A3 booting off the CD on a laptop that has only a
PCMCIA 3COM network card that worked in Shrike.  VT3 has messages like:

module(s) yenta_socket no found
/tmp/ds.o: init_module:
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
* failed to insert /tmp/ds.o

If I try to force it to load the 3c574_cs module, that is probed by the Shrike
installer, it prints the same error about ds.o, and then:

/tmp/cs574_cs.o: unresolved symbol register_pccard_driver_R1c442d6c
/tmp/cs574_cs.o: unresolved symbol unregister_pccard_driver_Rdb348cd2
* failed to insert /tmp/3c574_cs.o

Suggestions?  Do I need a fixed driver disk or something?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to do a network install on a Toshiba Tecra 8100 with only an external 3COM
network card that uses the 3c574_cs module.

Actual Results:  It doesn't recognize the network card due to dependency module
errors.

Expected Results:  It should recognize the driver, just like Shrike does.

Additional info:

Comment 1 Christopher Blizzard 2003-06-23 15:41:09 UTC
-> over to the kernel folks

Comment 2 Alexandre Oliva 2003-07-25 00:44:58 UTC
Fixed in Severn beta1 (except that I still needed acpi=off, but that's bug 100528.


Note You need to log in before you can comment on or make changes to this bug.