Bug 978072 - RFE: Support roff as an uploadable format via the WebUI
RFE: Support roff as an uploadable format via the WebUI
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 19:20 EDT by Ruediger Landmann
Modified: 2015-08-06 01:55 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-15 22:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
manpage for touch (3.02 KB, application/x-troff-man)
2013-06-25 19:58 EDT, Ruediger Landmann
no flags Details

  None (edit)
Description Ruediger Landmann 2013-06-25 19:20:17 EDT
At the moment, manpage translation requires a tool like po4a on the translator's or maintainer's side. If Zanata could support roff natively, it would lower the barrier to engagement in translating manpages: Zanata would read the roff files and output PO files that would be packaged with the software.
Comment 2 Ruediger Landmann 2013-06-25 19:58:31 EDT
Created attachment 765330 [details]
manpage for touch
Comment 3 Ruediger Landmann 2013-06-25 19:58:58 EDT
Just looking at how we ship translated manpages; they're roff in the sources too, so it would make sense to be able to output roff rather than just PO. 

Also attaching a sample roff file for Isaac :)
Comment 5 Sean Flanigan 2013-11-18 23:56:02 EST
Some items to test:

1. Output from hook commands is shown by default.
2. Output from hook commands can be hidden if the attribute "quiet" is true.
3. "After" hooks can be run unconditionally if the attribute "always" is true, if a push/pull fails, or if a preceding hook fails.
4. Child process is terminated if the zanata client process is interrupted (eg Ctrl-C).
Comment 6 Ding-Yi Chen 2013-12-04 19:59:55 EST
Help Documentation should be located in zanata,org and under the section that explain how to use client.
Comment 7 David Mason 2013-12-04 20:23:34 EST
Added link from zanata.org client configuration instructions to command hook instructions on the Zanata wiki.

See paragraph near the end of http://zanata.org/help/cli/cli-configuration/
Comment 8 Damian Jansen 2013-12-05 00:08:45 EST
Reading through the description and comments, I don't believe this feature was delivered in the requested form. What was delivered seems to be a workaround. To elaborate:

* "manpage translation requires a tool like po4a on the translator's or maintainer's side"
This is still the case, the hook needs to be operated on the user's side.

* "...could support roff natively, it would lower the barrier to engagement in translating manpages"
Someone with enough understanding of the configuration would have worked this out for themselves. The point seems to be it's for the average user, to upload and download roff files as per any other file.

* "Zanata would read the roff files..."
It does not - this is done before Zanata gets it. See previous point.

Perhaps there's something I missed, a decision to not directly support .roff but to do so in a "upload hook" manner that has been neglected to detail here.
Comment 9 Ding-Yi Chen 2013-12-05 01:01:18 EST
Ruedigner, do you think the command hook in zanata.xml is sufficient for your need. Or you still want native push/pull support. (That is, roff can be uploaded and downloaded through Web UI).
Comment 10 Sean Flanigan 2013-12-05 01:34:11 EST
We can't implement native support for every file format under the sun directly in Zanata, for reasons of server security and development capacity, which is why we chose a more general solution which will allow Zanata client to work with any format which has command-line converters.

Command hooks provide a solution not just for roff, but for other file formats too.  But perhaps we should have split it out into a separate RFE, and left this one alone.
Comment 11 Ding-Yi Chen 2013-12-05 02:03:48 EST
The functionality of command hook in zanata.xml is now traced by Bug 1038449
Comment 12 Akira TAGOH 2014-05-27 07:11:02 EDT
So what's the status on this feature at this point?
Comment 13 David Mason 2014-05-27 19:52:45 EDT
(In reply to Akira TAGOH from comment #12)
> So what's the status on this feature at this point?

At the moment the command hook feature has been implemented as a workaround to prevent having to manually run roff conversion scripts (initial setup is still required), but there is no native support for roff. I do not know of any immediate plan to work on this in the next couple of months.

If we find a good java library that can parse roff format, I think this could be achieved without much effort, but if we have to write a roff parser ourselves we will have to wait until we have more available time.
Comment 14 Ruediger Landmann 2014-12-15 22:27:15 EST
This feature is no longer a priority for CCS; closing

Note You need to log in before you can comment on or make changes to this bug.