Bug 97826 - httpd-2.0.45 segfault after SIGHUP
httpd-2.0.45 segfault after SIGHUP
Status: CLOSED DUPLICATE of bug 97207
Product: Red Hat Raw Hide
Classification: Retired
Component: httpd (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-22 12:54 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-22 12:54:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 
1.1.4322)

Description of problem:
Hi RedHat people:
I'm testing the httpd-2.0.45-10 of rawhide with php-4.3.2, but I'm having a 
very strange problem, the webserver works for some days, and suddenly without 
even any visits, the server crash and stops, here the message log...

[Sun Jun 22 04:02:11 2003] [notice] Digest: generating secret for digest 
authentication ...
[Sun Jun 22 04:02:11 2003] [notice] Digest: done
[Sun Jun 22 04:02:11 2003] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Sun Jun 22 04:02:11 2003] [notice] LDAP: SSL support unavailable
[Sun Jun 22 04:02:12 2003] [notice] seg fault or similar nasty error detected 
in the parent 

Version-Release number of selected component (if applicable):
httpd-2.0.45-10

How reproducible:
Always

Steps to Reproduce:
1. start httpd
2. let httpd works some days 

Actual Results:  The server stops

Additional info:
Comment 1 Joe Orton 2003-06-24 07:12:41 EDT
What are the lines before that in the error_log? Has the server just been
restared by logrotate?
Comment 2 Need Real Name 2003-06-24 12:38:42 EDT
Hi Jorton:
Hey I checked the cause, the problem is as you say after the logrotate, after 
the execution of:
/bin/kill -HUP `cat /var/run/httpd.pid 2>/dev/null` 2> /dev/null || true

the server stops and never starts again.
More information: First I thought it was a problem with APR so I built httpd 
with internal apr but the problem persists, ok I update to 2.0.46 and is still 
there...
                                    Regards Aliet
Comment 3 Joe Orton 2003-06-24 13:00:35 EDT
OK, thanks.  Can you confirm what set of modules you have loaded - run:

# rpm -qf /usr/lib/httpd/modules/*.so | sort -u

Comment 4 Need Real Name 2003-06-24 17:57:07 EDT
Hi Jorton I found the problem:
I'm using php-accelerator from www.php-accelerator.co.uk, everything looks like 
if there is some kind of conflict with php-accelerator and php-snmp, I tested 
against all other modules and works ok, but when snmp is included then then 
httpd stops on SIGHUP, the strange is that if you restart the server works, but 
when is throught the signal stops, also when the server is started they work 
together ok, here the error log, I dont´t know who I better report this issue
(php people, php-accelerator people, of httpd people)...


[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:44:00 2003] [notice] SIGHUP received.  Attempting to restart
[Tue Jun 24 17:43:29 2003] [notice-phpa] Acquiring cache : uid 48 gid 48 perms 
666 (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] PHPA 1.3.3r2 on linux_i686_glibc2.1.3 
(pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Initialised 8MB cache at 0x40d0a000 
with 512 process entries (pid 6216)
[Tue Jun 24 17:43:29 2003] [notice-phpa] Lock thresholds 10/10 (pid 6216)
[Tue Jun 24 17:44:00 2003] [notice-phpa] Cache shared memory removed (pid 6216)
[Tue Jun 24 17:44:00 2003] [notice-phpa] Cache semaphores removed (pid 6216)
[Tue Jun 24 17:44:01 2003] [notice] Digest: generating secret for digest 
authentication ...
[Tue Jun 24 17:44:01 2003] [notice] Digest: done
[Tue Jun 24 17:44:01 2003] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 24 17:44:01 2003] [notice] LDAP: SSL support unavailable
[Tue Jun 24 17:44:02 2003] [notice] seg fault or similar nasty error detected 
in the parent process
Comment 5 Joe Orton 2003-06-25 03:45:42 EDT
OK, thanks.  If php-snmp is the cause, this is probably a duplicate of bug 97207
then.
Comment 6 Cott Lang 2003-06-25 13:34:03 EDT
I have this exact same problem with httpd-2.0.40-21.3 WITHOUT php-snmp installed.

It's very intermittent; among 3 servers it happens about once a week.

I can't seem to get a core dump out of it despite setting my CoreDumpDirectory
to /tmp and adding ulimit -c 100000 in /etc/init.d/httpd just before daemon
$httpd $OPTIONS

On a related note, I have a constant problem with the parent httpd process
hogging 100% of a CPU several times each day. -HUPing the parent process fixes
it.  (I'll open a separate bug)


Comment 7 Need Real Name 2003-06-26 15:27:31 EDT
My Solution to this was:
I update to httpd-2.0.46, remove dav related patch, built httpd with internal
apr,  built php with apxs2 I mean throught the handler, not the filter, remove
all apache2filter related patch, remove all external apr patches, and boys is
working now, and very very stable....
                                              Regards
Comment 8 Joe Orton 2003-09-08 05:40:45 EDT
Marking as duplicate of 97207 given no other clues.

Cott, can you open a second bug on your problem with segfaults on RHL9? 
Unfortunately you can't get httpd to segfault with the up2date 9 kernel due to a
kernel bug in the ptrace fixes.  (you can back down to an old 9 kernel to get
them working again IIRC)

*** This bug has been marked as a duplicate of 97207 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:56:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.