Bug 978389 - RFE: support the config options suggested in the refarch
RFE: support the config options suggested in the refarch
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
high Severity unspecified
: ---
: 5.0 (RHEL 7)
Assigned To: Martin Magr
Ami Jeain
: FutureFeature
Depends On: 994568
Blocks: RHOS50RFE
  Show dependency treegraph
 
Reported: 2013-06-26 10:04 EDT by Giulio Fidente
Modified: 2016-04-26 17:41 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 07:07:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio Fidente 2013-06-26 10:04:17 EDT
Description of problem:
as per our refarch, it'd be nice to make packstack capable of configure the nova network/metadata service on multiple nodes


Version-Release number of selected component (if applicable):
Name        : openstack-packstack
Arch        : noarch
Version     : 2013.1.1
Release     : 0.20.dev632.el6ost
Comment 7 Giulio Fidente 2013-08-12 06:38:40 EDT
@mmagr: my general idea is that, in relation to the openstack components only, packstack should allow for the automated installation of the topology we're proposing via the "validation"/"ref arch" documents

As a general purpose openstack installation tool, I think packstack should *not* try to configure my Gluster volumes, the QPID clustering or the MySQL replication because these are all *external* tools to openstack.

Instead I'd expect packstack to provide options to point at some pre-existing installations of those services as also as the required options to configure the openstack components accordingly.

To add some specifics, looking at the docspace document[1], the "working" points I see are the following:

- UC4 -- Load balance controller services: packstack should allow for the deployment and configuration of multiple "controller" nodes so that these can be balanced by some external tool/hardware

- UC5 -- RHS-backed Cinder and Glance: packstack should allow for the configuration of Cinder/Nova/Glance for use with Gluster

- UC6 -- Configure Quantum Networking on the Controller Nodes: packstack should allow for the Neutron configuration as per suggestion

1. https://docspace.corp.redhat.com/docs/DOC-144251
Comment 8 Alvaro Lopez Ortega 2013-08-28 07:05:28 EDT
I'm afraid it won't be possible to implement it in the RHOS4 timeframe.
Comment 9 Alvaro Lopez Ortega 2013-09-24 12:25:22 EDT
Out of the list of requirements, in the RHOS 4.0 we'll have
- Multinode Nova is WIP
- MySQL optional installation
- GlusterFS

and we won't have:
- Multiple Qpid broke
- HA proxy installation
- Multiple API hosts for Glance, Cinder, Keystone and Nova
Comment 10 Alvaro Lopez Ortega 2013-09-24 12:27:06 EDT
UC5 and UC6 are implemented. UC4 is missing and won't be implemented in the RHOS 4.0 timeframe.
Comment 11 Rami Vaknin 2013-09-30 04:15:06 EDT
(In reply to Alvaro Lopez Ortega from comment #10)
> UC5 and UC6 are implemented. UC4 is missing and won't be implemented in the
> RHOS 4.0 timeframe.


Hi, could you please elaborate on what does "implementing multiple metadata nodes" means?

Seperating the Quantum metadata agent from the Quantum metadata proxy won't work due to the current implementation that uses Unix Socket Domain for communication between them, the only option to implement multiple metadata nodes means to run multiple Quantum metadata agents along with multiple Quantum metadata proxies, is that what UC6 referring to?
Comment 12 Martin Magr 2013-09-30 05:25:38 EDT
Not sure what are you writing about. The only one who mentioned "implementing multiple metadata nodes" is you Rami.
Comment 13 Rami Vaknin 2013-09-30 06:16:22 EDT
(In reply to Martin Magr from comment #12)
> Not sure what are you writing about. The only one who mentioned
> "implementing multiple metadata nodes" is you Rami.


I'm talking about:

"UC6 -- Configure Quantum Networking on the Controller Nodes
> Q-service and Q-plugin on service nodes (OVS)
> Network nodes (Agents: DHCP, L3, Meta-data proxy, L2)..."

from: https://docspace.corp.redhat.com/docs/DOC-144251
Comment 14 Martin Magr 2014-06-19 07:07:01 EDT
This is out of scope.

Note You need to log in before you can comment on or make changes to this bug.